summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 01:24:48 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:21 +0200
commit0ea695f67754c18a85d384dd32602f0a998549e0 (patch)
treefd269596678e14f0019638d510d2d821b536227d /gnu/packages/haskell-web.scm
parent12ce5d31d19bd40f71b1f7b865fe32dbf5f0848f (diff)
downloadpatches-0ea695f67754c18a85d384dd32602f0a998549e0.tar
patches-0ea695f67754c18a85d384dd32602f0a998549e0.tar.gz
gnu: ghc-yesod-core: Update to 1.6.6.
* gnu/packages/haskell-web.scm (ghc-yesod-core): Update to 1.6.6. [inputs]: Add ghc-unliftio and ghc-rio.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 9f96727a86..2271e1e982 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1069,7 +1069,7 @@ avoid any issues with characters.")
(define-public ghc-yesod-core
(package
(name "ghc-yesod-core")
- (version "1.4.37")
+ (version "1.6.6")
(source
(origin
(method url-fetch)
@@ -1078,7 +1078,7 @@ avoid any issues with characters.")
"yesod-core-" version ".tar.gz"))
(sha256
(base32
- "0ww8hl0cx2g58zrdx3j6d5m2xwhssbajdqws1xk6rzl7rpfm1b9j"))))
+ "0xahf6m5c7mkl74p0gimy4wb5w4s3lh92wwxmk517fbq666c92kb"))))
(build-system haskell-build-system)
(inputs `(("ghc-wai" ,ghc-wai)
("ghc-extra" ,ghc-extra)
@@ -1089,6 +1089,7 @@ avoid any issues with characters.")
("ghc-random" ,ghc-random)
("ghc-cereal" ,ghc-cereal)
("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-unliftio" ,ghc-unliftio)
("ghc-unordered-containers" ,ghc-unordered-containers)
("ghc-monad-control" ,ghc-monad-control)
("ghc-transformers-base" ,ghc-transformers-base)
@@ -1103,6 +1104,7 @@ avoid any issues with characters.")
("ghc-monad-logger" ,ghc-monad-logger)
("ghc-conduit" ,ghc-conduit)
("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-rio" ,ghc-rio)
("ghc-lifted-base" ,ghc-lifted-base)
("ghc-blaze-html" ,ghc-blaze-html)
("ghc-blaze-markup" ,ghc-blaze-markup)