summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 00:26:37 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:17 +0200
commit245a2555bcdd551cc6e0fe8fde6ccffa1248f741 (patch)
tree98c8483c18b277ca2a1af2e8ffc1aefb73f43359 /gnu/packages/haskell-crypto.scm
parent0618a71b1e5d0e5d79b440509791c49740a43f38 (diff)
downloadpatches-245a2555bcdd551cc6e0fe8fde6ccffa1248f741.tar
patches-245a2555bcdd551cc6e0fe8fde6ccffa1248f741.tar.gz
gnu: ghc-x509-store: Update to 1.6.6.
* gnu/packages/haskell-crypto.scm (ghc-x509-store): Update to 1.6.6. [native-inputs]: Add ghc-tasty and ghc-tasty-hunit.
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index cff678d724..9903555e6b 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -452,7 +452,7 @@ libraries, like OpenSSL.")
(define-public ghc-x509-store
(package
(name "ghc-x509-store")
- (version "1.6.2")
+ (version "1.6.6")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -460,7 +460,7 @@ libraries, like OpenSSL.")
version ".tar.gz"))
(sha256
(base32
- "0yw09nwkvr324qz4sc27c0p28bz2h6gns6lkaz9mz92mgqf2dza9"))))
+ "0dbndqmnmyixxc7308nyq3zlkhz9dff4rbcw2a49c77rbicny9va"))))
(build-system haskell-build-system)
(inputs
`(("ghc-pem" ,ghc-pem)
@@ -468,6 +468,9 @@ libraries, like OpenSSL.")
("ghc-asn1-encoding" ,ghc-asn1-encoding)
("ghc-cryptonite" ,ghc-cryptonite)
("ghc-x509" ,ghc-x509)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
(home-page "https://github.com/vincenthz/hs-certificate")
(synopsis "X.509 collection accessing and storing methods")
(description