summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2020-02-22 09:56:36 -0500
committerGuix Patches Tester <>2020-02-22 15:36:13 +0000
commit7a1f5ef1822a80ec7b6edc57921cd7f6837bb237 (patch)
treeb44a1e0daa0cfff0a7baf727e7d027f04ef81ab9 /gnu/packages/haskell-crypto.scm
parent9a3971143854bf877c0739fc8fdf7b945a2e3935 (diff)
downloadpatches-7a1f5ef1822a80ec7b6edc57921cd7f6837bb237.tar
patches-7a1f5ef1822a80ec7b6edc57921cd7f6837bb237.tar.gz
build-system/haskell: Add 'extra-directories?' keyword.series-2978
See <https://bugs.gnu.org/39309>. * guix/build-system/haskell.scm (haskell-build): Add 'extra-directories?' keyword and pass it through to the builder. * guix/build/haskell-build-system.scm (configure): Use it to toggle passing 'extra-include-dirs' and 'extra-lib-dirs' to Cabal. * gnu/packages/haskell-xyz.scm (ghc-alsa-core, ghc-hmatrix, ghc-hmatrix-gsl, ghc-hslua, ghc-iwlib, ghc-libyaml, ghc-ncurses, ghc-openglraw, ghc-x11, ghc-x11-xft, ghc-zlib): Enable 'extra-directories?'. gnu/packages/haskell-crypto.scm (ghc-digest, ghc-hsopenssl): Likewise.
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 4170ec82f0..637a5d421e 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -343,6 +343,8 @@ generators, and more.")
(base32
"04gy2zp8yzvv7j9bdfvmfzcz3sqyqa6rwslqcn4vyair2vmif5v4"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:extra-directories? #t))
(inputs
`(("zlib" ,zlib)))
(home-page
@@ -790,6 +792,8 @@ extensions.")
(base32
"0qivl9clmybfglwxqp2sq308rv4ia4rhwshcsc8b029bvpp0mpsi"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:extra-directories? #t))
(inputs
`(("ghc-network" ,ghc-network)
("openssl" ,openssl)))