summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-09-06 20:46:00 -0400
committerMark H Weaver <mhw@netris.org>2019-09-06 20:46:00 -0400
commit65542a8852759f35e19959149ac92297c8b54be5 (patch)
treebc8f398c7b10a4725b20aa59ab1452d30f358ea3 /gnu/packages/haskell-check.scm
parentbc60349b5bc58a0b803df5adce1de6db82453744 (diff)
parentf66aee3d0d2f573187ed5d44ae7c13d73cd4097a (diff)
downloadpatches-65542a8852759f35e19959149ac92297c8b54be5.tar
patches-65542a8852759f35e19959149ac92297c8b54be5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 589eee74d9..e0951d489c 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -28,8 +28,8 @@
(define-module (gnu packages haskell-check)
#:use-module (gnu packages)
- #:use-module (gnu packages haskell)
#:use-module (gnu packages haskell-crypto)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (guix build-system haskell)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
@@ -837,3 +837,28 @@ of generated values by construction.
To get started quickly, see the examples:
@uref{https://github.com/hedgehogqa/haskell-hedgehog/tree/master/hedgehog-example}")
(license license:bsd-3)))
+
+(define-public cabal-doctest
+ (package
+ (name "cabal-doctest")
+ (version "1.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "cabal-doctest/cabal-doctest-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0bgd4jdmzxq5y465r4sf4jv2ix73yvblnr4c9wyazazafddamjny"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("1" "1bk85avgc93yvcggwbk01fy8nvg6753wgmaanhkry0hz55h7mpld")))
+ (home-page "https://github.com/phadej/cabal-doctest")
+ (synopsis "Setup.hs helper for running doctests")
+ (description
+ "To properly work, the @code{doctest} package needs plenty of
+configuration. This library provides the common bits for writing custom
+@file{Setup.hs} files.")
+ (license license:bsd-3)))