summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-08-16 07:20:28 -0700
committerLudovic Courtès <ludo@gnu.org>2019-09-01 23:02:23 +0200
commit83f9448eb1207e66d31ff42b4995115995a94eff (patch)
tree5e4c0a9d7af3a4944d96b70116017fdd639779cd /gnu/packages/haskell-apps.scm
parent867df63f90a21a7585b35f44b95d49c0a6f07e7d (diff)
downloadpatches-83f9448eb1207e66d31ff42b4995115995a94eff.tar
patches-83f9448eb1207e66d31ff42b4995115995a94eff.tar.gz
gnu: Add stylish-haskell.
* gnu/packages/haskell-apps (stylish-haskell): new variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 28502eb87f..77199af2cb 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -513,3 +513,38 @@ that cause a shell to behave strangely and counter-intuitively.
advanced user's otherwise working script to fail under future circumstances.
@end enumerate")
(license license:gpl3+)))
+
+(define-public stylish-haskell
+ (package
+ (name "stylish-haskell")
+ (version "0.9.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "mirror://hackage/package/stylish-haskell/"
+ "stylish-haskell-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zs624xqp6j8vrl6pfv18dm8vz8hvz25grri65ximxhcizgwhnax"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-file-embed" ,ghc-file-embed)
+ ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-yaml" ,ghc-yaml)
+ ("ghc-strict" ,ghc-strict)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
+ (home-page "https://github.com/jaspervdj/stylish-haskell")
+ (synopsis "Haskell code prettifier")
+ (description
+ "A simple Haskell code prettifier. The goal is not to format all of the
+code in a file, just clean up import statements and a few other tedious
+items. This tool tries to help where necessary without getting in the way.")
+ (license license:bsd-3)))