summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:31:50 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:44 -0500
commit12ee2d5d8466578b8cde03fa5a91ca15efcb3b4c (patch)
tree7e51eef8ad7bcccd5a4b90e15fe6f5e7712c40f9 /gnu/packages/haskell-apps.scm
parent2648b604ac112839933b450ad21f01fb6a22a6ff (diff)
downloadpatches-12ee2d5d8466578b8cde03fa5a91ca15efcb3b4c.tar
patches-12ee2d5d8466578b8cde03fa5a91ca15efcb3b4c.tar.gz
gnu: hoogle: Update to 5.0.17.11.
* gnu/packages/haskell-apps.scm (hoogle): Update to 5.0.17.11. [inputs]: Remove 'ghc-network-uri' and 'ghc-network'; add 'ghc-blaze-html', 'ghc-blaze-markup', and 'ghc-foundation'.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 2192c1c8ff..682a10b327 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -443,7 +443,7 @@ unwanted suggestions, and to add your own custom suggestions.")
(define-public hoogle
(package
(name "hoogle")
- (version "5.0.17.3")
+ (version "5.0.17.11")
(source
(origin
(method url-fetch)
@@ -453,18 +453,19 @@ unwanted suggestions, and to add your own custom suggestions.")
version ".tar.gz"))
(sha256
(base32
- "174gp41v0krzj37m75pnr3aawyhkbk2wq4q6zk2z3zh0avvvmgk6"))))
+ "1svp8z9pad8z2j386pr0dda0ds8ddxab0salnz4gm51q877w93p1"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-network-uri" ,ghc-network-uri)
- ("ghc-network" ,ghc-network)
- ("ghc-quickcheck" ,ghc-quickcheck)
+ `(("ghc-quickcheck" ,ghc-quickcheck)
("ghc-aeson" ,ghc-aeson)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)
("ghc-cmdargs" ,ghc-cmdargs)
("ghc-conduit" ,ghc-conduit)
("ghc-conduit-extra" ,ghc-conduit-extra)
("ghc-connection" ,ghc-connection)
("ghc-extra" ,ghc-extra)
+ ("ghc-foundation" ,ghc-foundation)
("ghc-old-locale" ,ghc-old-locale)
("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
("ghc-http-conduit" ,ghc-http-conduit)