summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-30 14:34:40 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-30 15:19:32 +0100
commit528ea990c3a815cb4b0ded913ea22cdc778839bd (patch)
tree5803e0a9b9f6a1a384b5bb306a0899f13dc7e65e /gnu/packages/guile.scm
parent398747f8f11dc011799da1c2384aa201488a4595 (diff)
downloadpatches-528ea990c3a815cb4b0ded913ea22cdc778839bd.tar
patches-528ea990c3a815cb4b0ded913ea22cdc778839bd.tar.gz
gnu: Use 'this-package' as a native input instead of 'self-native-input?'.
* gnu/packages/file.scm (file)[self-native-input?]: Remove. [native-inputs]: New field. * gnu/packages/guile.scm (guile-1.8)[self-native-input?]: Remove. [native-inputs]: New field. (guile-2.0)[self-native-input?]: Remove. [native-inputs]: Add THIS-PACKAGE when (%current-target-system) is true. * gnu/packages/ncurses.scm (ncurses)[self-native-input?]: Remove. [native-inputs]: Add THIS-PACKAGE when (%current-target-system) is true. * gnu/packages/python-xyz.scm (python-file)[self-native-input?]: Remove. [native-inputs]: New field.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index daeadca610..5903bcabaa 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -103,6 +103,12 @@
(substitute* "ice-9/popen.scm"
(("/bin/sh") (which "sh")))
#t)))))
+
+ ;; When cross-compiling, a native version of Guile itself is needed.
+ (native-inputs (if (%current-target-system)
+ `(("self" ,this-package))
+ '()))
+
(inputs `(("gawk" ,gawk)
("readline" ,readline)))
@@ -111,9 +117,6 @@
(propagated-inputs `(("gmp" ,gmp)
("libltdl" ,libltdl)))
- ;; When cross-compiling, a native version of Guile itself is needed.
- (self-native-input? #t)
-
(native-search-paths
(list (search-path-specification
(variable "GUILE_LOAD_PATH")
@@ -141,7 +144,12 @@ without requiring the source code to be rewritten.")
(base32
"10lxc6l5alf3lzbs3ihnbfy6dfcrsyf8667wa57f26vf4mk2ai78"))))
(build-system gnu-build-system)
- (native-inputs `(("pkgconfig" ,pkg-config)))
+
+ ;; When cross-compiling, a native version of Guile itself is needed.
+ (native-inputs `(,@(if (%current-target-system)
+ `(("self" ,this-package))
+ '())
+ ("pkgconfig" ,pkg-config)))
(inputs `(("libffi" ,libffi)
,@(libiconv-if-needed)
@@ -165,8 +173,6 @@ without requiring the source code to be rewritten.")
("bdw-gc" ,libgc)
("gmp" ,gmp)))
- (self-native-input? #t)
-
(outputs '("out" "debug"))
(arguments