summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-21 22:39:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-21 22:39:42 +0100
commit8ed9be3faccb865204de46d2a8ed3e96e59281b6 (patch)
tree77ba4c90cda569048bc9ce2e414ede1567130c88 /gnu/packages/guile.scm
parent36930b2463fc933e7c5580f49413dbd14cf1df48 (diff)
parent715110a8a2e9e4b1a89635950744eb5260b8ee7f (diff)
downloadpatches-8ed9be3faccb865204de46d2a8ed3e96e59281b6.tar
patches-8ed9be3faccb865204de46d2a8ed3e96e59281b6.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm49
1 files changed, 16 insertions, 33 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 803885ab7e..cba4d363e1 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -272,19 +272,19 @@ without requiring the source code to be rewritten.")
(base32
"07p3g0v2ba2vlfbfidqzlgbhnzdx46wh2rgc5gszq1mjyx5bks6r"))))))
-(define-public guile-next
- ;; This is the upcoming Guile 3.0, with JIT support.
+(define-public guile-3.0
+ ;; This is the latest Guile stable version.
(package
(inherit guile-2.2)
- (name "guile-next")
- (version "2.9.9")
+ (name "guile-next") ;to be renamed to "guile"
+ (version "3.0.0")
(source (origin
(inherit (package-source guile-2.2))
- (uri (string-append "ftp://alpha.gnu.org/gnu/guile/guile-"
+ (uri (string-append "ftp://ftp.gnu.org/gnu/guile/guile-"
version ".tar.xz"))
(sha256
(base32
- "0s99zzdzj29fb42q5fwn7vqg9k7y9ppq9vkv4p39zr93z8694wdz"))))
+ "0x8ca6q1qdmk29lh12gj6ngvgn7kp79w42rxfgwrpxm9jmjqs4y9"))))
(native-search-paths
(list (search-path-specification
(variable "GUILE_LOAD_PATH")
@@ -292,9 +292,9 @@ without requiring the source code to be rewritten.")
(search-path-specification
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/3.0/site-ccache"
- "share/guile/site/3.0")))))
- (properties '((ftp-server . "alpha.gnu.org")
- (upstream-name . "guile")))))
+ "share/guile/site/3.0")))))))
+
+(define-public guile-next guile-3.0)
(define* (make-guile-readline guile #:optional (name "guile-readline"))
(package
@@ -626,36 +626,19 @@ type system, elevating types to first-class status.")
(define-public guile-git
(package
(name "guile-git")
- (version "0.2.0")
+ (version "0.3.0")
(home-page "https://gitlab.com/guile-git/guile-git.git")
(source (origin
- (method git-fetch)
- (uri (git-reference (url home-page)
- (commit (string-append "v" version))))
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/guile-git/guile-git/uploads/"
+ "4c563d8e7e1ff84396abe8ca7011bcaf/guile-git-"
+ version ".tar.gz"))
(sha256
(base32
- "018hmfsh0rjwfvr4h7y10jc6k8a2k9xsirngghy3pjasin4nd2yz"))
- (file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Allow builds with Guile 3.0.
- (substitute* "configure.ac"
- (("^GUILE_PKG.*")
- "GUILE_PKG([3.0 2.2 2.0])\n"))
-
- ;; The 'guile.m4' that's shipped is too old and fails to
- ;; recognize Guile 2.9/3.0. Delete it and pick the one
- ;; provided by the Guile we're using.
- (delete-file "m4/guile.m4")
-
- #t))))
+ "0c5i3d16hp7gp9rd78vk9zc45js8bphf92m4lbb5gyi4l1yl7kkm"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("texinfo" ,texinfo)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("guile" ,guile-2.2)
("libgit2" ,libgit2)))