summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-21 18:00:17 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-21 18:18:06 +0200
commit1dcca83afbc2a5b66f61f389971d257d2d65100d (patch)
tree7bc83bce345877b07e877305a73797017df6db38 /gnu/packages/guile.scm
parent8bdacad26b1209dd4d95f5ca093a9178feb12f5b (diff)
downloadpatches-1dcca83afbc2a5b66f61f389971d257d2d65100d.tar
patches-1dcca83afbc2a5b66f61f389971d257d2d65100d.tar.gz
gnu: guile: Update to 2.2.5.
* gnu/packages/guile.scm (guile-2.2): Update to 2.2.5. [arguments]: Remove. (guile-2.2.5): Remove.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm47
1 files changed, 3 insertions, 44 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 25077e4f75..efb19b456f 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -216,7 +216,7 @@ without requiring the source code to be rewritten.")
(define-public guile-2.2
(package (inherit guile-2.0)
(name "guile")
- (version "2.2.4")
+ (version "2.2.5")
(source (origin
(method url-fetch)
@@ -226,7 +226,7 @@ without requiring the source code to be rewritten.")
".tar.xz"))
(sha256
(base32
- "07p3g0v2ba2vlfbfidqzlgbhnzdx46wh2rgc5gszq1mjyx5bks6r"))
+ "19w5ws1jvs01dpv756qv2cgs37rsnwq1f4f07mj0wra35pqp6c7w"))
(modules '((guix build utils)))
(patches (search-patches
"guile-2.2-skip-oom-test.patch"))
@@ -247,36 +247,7 @@ without requiring the source code to be rewritten.")
(files '("share/guile/site/2.2")))
(search-path-specification
(variable "GUILE_LOAD_COMPILED_PATH")
- (files '("lib/guile/2.2/site-ccache")))))
-
- (arguments
- (if (%current-target-system)
- (substitute-keyword-arguments (package-arguments guile-2.0)
- ((#:phases phases '%standard-phases)
- `(modify-phases ,phases
- (add-after 'unpack 'sacrifice-elisp-support
- (lambda _
- ;; Cross-compiling language/elisp/boot.el fails, so
- ;; sacrifice it. See
- ;; <https://git.savannah.gnu.org/cgit/guile.git/commit/?h=stable-2.2&id=988aa29238fca862c7e2cb55f15762a69b4c16ce>
- ;; for the upstream fix.
- (substitute* "module/Makefile.in"
- (("language/elisp/boot\\.el")
- "\n"))
- #t))
- ,@(if (hurd-target?)
- `((add-after 'unpack 'allow-madvise-ENOSYS
- (lambda _
- ;; Do not warn about ENOSYS on 'madvise'. This is
- ;; what Guile commit
- ;; 45e4ace6603e00b297e6542362273041aebe7305 does.
- ;; TODO: Remove for Guile >= 2.2.5.
- (substitute* "libguile/vm.c"
- (("perror \\(\"madvise failed\"\\)")
- "if (errno != ENOSYS) perror (\"madvised failed\");"))
- #t)))
- '()))))
- (package-arguments guile-2.0)))))
+ (files '("lib/guile/2.2/site-ccache")))))))
(define-public guile-2.2/fixed
;; A package of Guile 2.2 that's rarely changed. It is the one used
@@ -288,18 +259,6 @@ without requiring the source code to be rewritten.")
(max-silent-time . 36000))))) ;10 hours (needed on ARM
; when heavily loaded)
-(define-public guile-2.2.5
- (package
- (inherit guile-2.2)
- (version "2.2.5")
- (source (origin
- (inherit (package-source guile-2.2))
- (uri (string-append "mirror://gnu/guile/guile-" version
- ".tar.xz"))
- (sha256
- (base32
- "19w5ws1jvs01dpv756qv2cgs37rsnwq1f4f07mj0wra35pqp6c7w"))))))
-
(define-public guile-next
;; This is the upcoming Guile 3.0, with JIT support.
(let ((commit "6f3357b0df64c4be17e72079864c09a542f1c779")