summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-10-08 10:30:39 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-08 22:01:55 +0200
commite076d56a6f5f9b9134fb0f164caf44d496c4a0e9 (patch)
treed29530e8826390733639992e4f0391fd7649a142 /gnu/packages/guile.scm
parent5e66574a128937e7f2fcf146d146225703ccfd5d (diff)
downloadpatches-e076d56a6f5f9b9134fb0f164caf44d496c4a0e9.tar
patches-e076d56a6f5f9b9134fb0f164caf44d496c4a0e9.tar.gz
gnu: Add guile-colorized.
* gnu/packages/guile.scm (guile-colorized): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 65d252617b..e32ca84a7f 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2017 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
+;;; Copyright © 2017 ng0 <ng0@infotropique.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1966,4 +1967,49 @@ HTML (via SXML) or any other format for rendering.")
It has a nice, simple s-expression based syntax.")
(license license:lgpl3+)))
+(define-public guile-colorized
+ (package
+ (name "guile-colorized")
+ (version "0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/NalaGinrut/guile-colorized/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16xhc3an6aglnca8xl3mvgi8hsqzqn68vsl5ga4bz8bvbap5fn4p"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:modules ((system base compile)
+ ,@%gnu-build-system-modules)
+ #:tests? #f ;No tests included
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;No configure script
+ (replace 'install
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (module-dir (string-append out "/share/guile/site/2.2"))
+ (language-dir (string-append module-dir "/ice-9"))
+ (guild (string-append (assoc-ref inputs "guile")
+ "/bin/guild")))
+ ;; The original 'make install' is too primitive.
+
+ ;; copy the source
+ (install-file "ice-9/colorized.scm" language-dir)
+
+ ;; compile to the destination
+ (compile-file "ice-9/colorized.scm"
+ #:output-file (string-append
+ language-dir "/colorized.go"))
+ #t))))))
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (home-page "https://github.com/NalaGinrut/guile-colorized")
+ (synopsis "Colorized REPL for Guile")
+ (description
+ "Guile-colorized provides you with a colorized REPL for GNU Guile.")
+ (license license:gpl3+)))
+
;;; guile.scm ends here