summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-06-20 00:29:31 -0400
committerMark H Weaver <mhw@netris.org>2017-06-20 00:29:31 -0400
commita9308efec642bfbce480545a22fce848e6212456 (patch)
treeb56f696937d8531800959d0f1deee4683ab425d2 /gnu/packages/guile.scm
parent9815739e9bc5de4a4fbcc710221c2cee377664d4 (diff)
downloadpatches-a9308efec642bfbce480545a22fce848e6212456.tar
patches-a9308efec642bfbce480545a22fce848e6212456.tar.gz
gnu: guile-2.2/fixed: Increase timeout and max-silent-time.
* gnu/packages/guile.scm (guile-2.2/fixed)[properties]: Add 'timeout' and 'max-silent-time' properties.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 5577ad98e7..85faec6c47 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -255,7 +255,10 @@ without requiring the source code to be rewritten.")
;; in the `base' module, and thus changing it entails a full rebuild.
(package
(inherit guile-2.2)
- (properties '((hidden? . #t))) ;people should install 'guile-2.2'
+ (properties '((hidden? . #t) ;people should install 'guile-2.2'
+ (timeout . 72000) ;20 hours
+ (max-silent-time . 36000))) ;10 hours (needed on ARM
+ ; when heavily loaded)
(replacement #f)))
(define-public guile-next