summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authoramirouche <amirouche+dev@hypermove.net>2018-01-08 22:30:10 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-11 14:07:30 +0100
commit4f85f7f7ef99455784cac88e2775d19baad23690 (patch)
tree8d57b01e4b282ef9f7a65ed4d4da19d0c8317c61 /gnu/packages/guile.scm
parent73244e634cfe3e4412455b5ee60972c85288149c (diff)
downloadpatches-4f85f7f7ef99455784cac88e2775d19baad23690.tar
patches-4f85f7f7ef99455784cac88e2775d19baad23690.tar.gz
gnu: guile-bytestructures: Update to 1.0.1.
* gnu/package/guile.scm (guile-bytestructures): Update to 1.0.1. [source]: Use tarball from github instead of git. [build-system]: Use GNU-BUILD-SYSTEM. [arguments]: Remove. [navitve-inputs]: Add PKG-CONFIG. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm88
1 files changed, 8 insertions, 80 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 887e360a35..a778bbf458 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1658,90 +1658,18 @@ is no support for parsing block and inline level HTML.")
(define-public guile-bytestructures
(package
(name "guile-bytestructures")
- (version "20170402.91d042e")
+ (version "1.0.1")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/TaylanUB/scheme-bytestructures")
- (commit "91d042e3427e1d7740b604b6296c616cf2eec13d")))
- (file-name (string-append name "-" version "-checkout"))
+ (method url-fetch)
+ (uri (string-append "https://github.com/TaylanUB/scheme-bytestructures"
+ "/releases/download/v" version
+ "/bytestructures-" version ".tar.gz"))
(sha256
(base32
- "04lgh0nk6ddnwgh20hnz4pyhczaik0xbd50kikjsxcwcl46shavb"))
- (patches (search-patches "guile-bytestructures-name-clash.patch"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils)
- (ice-9 ftw)
- (ice-9 match)
- (ice-9 popen)
- (ice-9 rdelim))
- ;; Unpack.
- (setenv "PATH"
- (string-join (list (assoc-ref %build-inputs "tar")
- (assoc-ref %build-inputs "xz"))
- "/bin:" 'suffix))
- (system* "tar" "xf" (assoc-ref %build-inputs "source"))
- (match (scandir ".")
- (("." ".." directory)
- (chdir directory)))
-
- (let* ((out (assoc-ref %outputs "out"))
- (guile (assoc-ref %build-inputs "guile"))
- (effective (read-line
- (open-pipe* OPEN_READ
- (string-append guile "/bin/guile")
- "-c" "(display (effective-version))")))
- (module-dir (string-append out "/share/guile/site/"
- effective))
- (object-dir (string-append out "/lib/guile/" effective
- "/site-ccache"))
- (source (getcwd))
- (doc (string-append out "/share/doc/scheme-bytestructures"))
- (sld-files (with-directory-excursion source
- (find-files "bytestructures/r7" "\\.exports.sld$")))
- (scm-files (filter (lambda (path)
- (not (string-prefix? "bytestructures/r7" path)))
- (with-directory-excursion source
- (find-files "bytestructures" "\\.scm$"))))
- (guild (string-append (assoc-ref %build-inputs "guile")
- "/bin/guild")))
- ;; Make installation directories.
- (mkdir-p doc)
-
- ;; Compile .scm files and install.
- (chdir source)
- (setenv "GUILE_AUTO_COMPILE" "0")
- (for-each (lambda (file)
- (let* ((dest-file (string-append module-dir "/"
- file))
- (go-file (string-append object-dir "/"
- (substring file 0
- (string-rindex file #\.))
- ".go")))
- ;; Install source module.
- (mkdir-p (dirname dest-file))
- (copy-file file dest-file)
-
- ;; Install compiled module.
- (mkdir-p (dirname go-file))
- (unless (zero? (system* guild "compile"
- "-L" source
- "-o" go-file
- file))
- (error (format #f "Failed to compile ~s to ~s!"
- file go-file)))))
- (append sld-files scm-files))
-
- ;; Also copy over the README.
- (install-file "README.md" doc)
- #t))))
+ "1lnfcy65mqj823lamy2n2vaghdz0g7mj011bgnhmd6hwpnaidnh2"))))
+ (build-system gnu-build-system)
(native-inputs
- `(("tar" ,tar)
- ("xz" ,xz)))
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("guile" ,guile-2.2)))
(home-page "https://github.com/TaylanUB/scheme-bytestructures")