summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-01-28 15:41:12 +0100
committerLudovic Courtès <ludo@gnu.org>2019-01-28 15:45:48 +0100
commit7d2be1277b44de9d0528d9d3015443b40cb3b104 (patch)
tree6c4f28a210edcd6b6d6d4528d5c143ad29805d5f /gnu/packages/guile.scm
parent796a4491fdaa4a0a3d669457b89356f9fbfc966e (diff)
downloadpatches-7d2be1277b44de9d0528d9d3015443b40cb3b104.tar
patches-7d2be1277b44de9d0528d9d3015443b40cb3b104.tar.gz
packages: 'package-input-rewriting' can take a promise.
* guix/packages.scm (package-input-rewriting): Allow REPLACEMENTS to be a promise. * gnu/packages/guile.scm (package-for-guile-2.0): Delay the first argument to 'package-input-rewriting'.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 869fec97bd..5f5d59da47 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -391,7 +391,7 @@ GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
(define package-for-guile-2.0
;; A procedure that rewrites the dependency tree of the given package to use
;; GUILE-2.0 instead of GUILE-2.2.
- (package-input-rewriting `((,guile-2.2 . ,guile-2.0))
+ (package-input-rewriting (delay `((,guile-2.2 . ,guile-2.0)))
(guile-variant-package-name "guile2.0")))
(define-public guile-for-guile-emacs