summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorAmirouche BOUBEKKI <amirouche@hypermove.net>2015-12-11 17:04:06 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-13 15:20:44 +0100
commitdec1e2b3520d00a910189425303aab1a7d2bd1c1 (patch)
tree1cc72e2a057f5531419bff00dc134e2b9cd74854 /gnu/packages/guile.scm
parent5568151f5b571346e8c1760a1e0be9d7fd01b665 (diff)
downloadpatches-dec1e2b3520d00a910189425303aab1a7d2bd1c1.tar
patches-dec1e2b3520d00a910189425303aab1a7d2bd1c1.tar.gz
gnu: Add g-wrap.
* gnu/packages/guile.scm (g-wrap): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index a4203f0f3b..4be237cd65 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -841,4 +841,32 @@ capabilities.")
(home-page "http://dthompson.us/pages/software/sly.html")
(license gpl3+)))
+(define-public g-wrap
+ (package
+ (name "g-wrap")
+ (version "1.9.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/g-wrap/g-wrap-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ak0bha37dfpj9kmyw1r8fj8nva639aw5xr66wr5gd3l1rqf5xhg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("guile" ,guile-2.0)
+ ("guile-lib" ,guile-lib)))
+ (inputs
+ `(("libffi" ,libffi)))
+ (synopsis "Generate C bindings for Guile")
+ (description "G-Wrap is a tool and Guile library for generating function
+wrappers for inter-language calls. It currently only supports generating Guile
+wrappers for C functions. Given a definition of the types and prototypes for
+a given C interface, G-Wrap will automatically generate the C code that
+provides access to that interface and its types from the Scheme level.")
+ (home-page "http://www.nongnu.org/g-wrap/index.html")
+ (license lgpl2.1+)))
+
;;; guile.scm ends here