summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-30 12:17:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-30 12:17:33 +0200
commitae0badf5bb791428423a98d4e4e2b8d297a5d4be (patch)
tree4282d243db3e90839a5f7d3b5878674ccd0e2e14 /gnu/packages/guile-xyz.scm
parentee401ed9249fbe284ef1b9b437d39207ca88131b (diff)
parent927f3655662b41f25225ea03baa3ded687aa7cbb (diff)
downloadpatches-ae0badf5bb791428423a98d4e4e2b8d297a5d4be.tar
patches-ae0badf5bb791428423a98d4e4e2b8d297a5d4be.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/packages/admin.scm gnu/packages/commencement.scm gnu/packages/guile.scm gnu/packages/linux.scm gnu/packages/package-management.scm gnu/packages/pulseaudio.scm gnu/packages/web.scm
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm50
1 files changed, 46 insertions, 4 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b181189b3a..f0f976c3d2 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019, 2020 Amar Singh <nly@disroot.org>
;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2238,10 +2239,6 @@ format is also supported.")
(define-public guile3.0-mcron
(deprecated-package "guile3.0-mcron" mcron))
-(define-public mcron2
- ;; This was mthl's mcron development branch, and it became mcron 1.1.
- (deprecated-package "mcron2" mcron))
-
(define-public guile-picture-language
(let ((commit "91d10c96708d732145006dd2802acc4de08b632e")
(revision "1"))
@@ -3298,3 +3295,48 @@ according to Bitorrent BEP003.")
Relay Chat} (IRC).")
;; Some file headers incorrectly say LGPLv2+.
(license license:lgpl2.1+))))
+
+(define-public guile3.0-websocket
+ (let ((commit "c854e0f84a40d972cbd532bbb89c97ca0126a7cf"))
+ (package
+ (name "guile3.0-websocket")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://dthompson.us/guile-websocket.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hymvsfrmq9qxr5cxnsgdz7y757yp1cpsgxmdp3f5wxxxpqgsmzx"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags
+ '("GUILE_AUTO_COMPILE=0")
+ #:phases
+ (modify-phases %standard-phases
+ ;; The package was developed for Guile 2.0 and has this version
+ ;; hardcoded in the configure.ac and Makefile.am files. Substitute
+ ;; 3.0 instead so it can support Guile 3.0.
+ (add-after 'unpack 'update-guile-version
+ (lambda _
+ (substitute* "configure.ac"
+ (("2.0.9") "3.0.0"))
+ (substitute* "Makefile.am"
+ (("2.0") "3.0")
+
+ ;; Install .go files where they belong.
+ (("/ccache") "/site-ccache"))
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs
+ `(("guile" ,guile-next)))
+ (synopsis "Websocket server/client for Guile")
+ (description "Guile-websocket provides an implementation of the
+WebSocket protocol as defined by RFC 6455.")
+ (home-page "https://git.dthompson.us/guile-websocket.git")
+ (license license:lgpl3+))))