summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorPatrick Hetu <patrick.hetu@auf.org>2016-05-28 18:01:48 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-28 18:06:15 +0200
commit9b381643f009025d97dfc0b82d2c00800c204380 (patch)
tree5e6b9134a9c4e988b85686bb5334a3968067bee4 /gnu/packages/gtk.scm
parent9fcc3509a7af4348d855141e60501d9728fd6b6f (diff)
downloadpatches-9b381643f009025d97dfc0b82d2c00800c204380.tar
patches-9b381643f009025d97dfc0b82d2c00800c204380.tar.gz
gnu: Add Guile-GNOME.
* gnu/packages/gtk.scm (guile-gnome): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 1fe52a4b83..e237c6a66d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016 Patrick Hetu <patrick.hetu@auf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -51,6 +52,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -822,6 +824,60 @@ includes a tools to generate PDF presentations out of Org mode and Texinfo
documents.")
(license license:lgpl3+)))
+(define-public guile-gnome
+ (package
+ (name "guile-gnome")
+ (version "2.16.4")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://gnu/" name
+ "/guile-gnome-platform/guile-gnome-platform-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1hqnqbb2lmr3hgbcv9kds1himn3av6h0lkk0zll8agcrsn7d9axd"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("atk" ,atk)
+ ;;("corba" ,corba) ; not packaged yet
+ ("gconf" ,gconf)
+ ("gobject-introspection" ,gobject-introspection)
+ ;;("gthread" ,gthread) ; not packaged yet
+ ("gnome-vfs" ,gnome-vfs)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gtk+" ,gtk+-2)
+ ("libglade" ,libglade)
+ ("libgnome" ,libgnome)
+ ("libgnomecanvas" ,libgnomecanvas)
+ ("libgnomeui" ,libgnomeui)
+ ("pango" ,pango)
+ ("libffi" ,libffi)
+ ("glib" ,glib)))
+ (inputs `(("guile" ,guile-2.0)))
+ (propagated-inputs
+ `(("guile-cairo" ,guile-cairo)
+ ("g-wrap" ,g-wrap)
+ ("guile-lib" ,guile-lib)))
+ (arguments
+ `(#:tests? #f ;FIXME
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (find-files "." "^Makefile.in$")
+ (("guilesite :=.*guile/site" all)
+ (string-append all "/2.0")))
+ #t))))))
+ (outputs '("out" "debug"))
+ (synopsis "Guile interface for GTK+ programming for GNOME")
+ (description
+ "Includes guile-clutter, guile-gnome-gstreamer,
+guile-gnome-platform (GNOME developer libraries), and guile-gtksourceview.")
+ (home-page "http://www.gnu.org/software/guile-gnome/")
+ (license license:gpl2+)))
+
;;;
;;; C++ bindings.
;;;