summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-05-15 12:51:27 +0800
committerLudovic Courtès <ludo@gnu.org>2019-05-20 23:23:01 +0200
commita32ecb5089c32a2080b315a5200078d1a303c656 (patch)
tree3d12e55ccae5b72af29b26d8bc7fb3dcd9b57b2b /gnu/packages/gtk.scm
parent758ffc234d45eeebd4e98773a16b36ba2f31f124 (diff)
downloadpatches-a32ecb5089c32a2080b315a5200078d1a303c656.tar
patches-a32ecb5089c32a2080b315a5200078d1a303c656.tar.gz
gnu: Add libdbusmenu.
* gnu/packages/gtk.scm (libdbusmenu): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 6e63ca6614..a885d35080 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1754,3 +1755,53 @@ popular spread sheet programs.")
shell scripts. Example of how to use @code{yad} can be consulted at
@url{https://sourceforge.net/p/yad-dialog/wiki/browse_pages/}.")
(license license:gpl3+)))
+
+(define-public libdbusmenu
+ (package
+ (name "libdbusmenu")
+ (version "16.04.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/libdbusmenu/"
+ (version-major+minor version) "/" version
+ "/+download/libdbusmenu-" version ".tar.gz"))
+ (sha256
+ (base32 "12l7z8dhl917iy9h02sxmpclnhkdjryn08r8i4sr8l3lrlm4mk5r"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ '("--sysconfdir=/etc"
+ "--localstatedir=/var"
+ ;; The shebang of the generated test files should be patched before
+ ;; enabling tests.
+ "--disable-tests")
+ #:make-flags
+ `(,(string-append "typelibdir=" (assoc-ref %outputs "out")
+ "/lib/girepository-1.0"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-environment
+ (lambda _
+ (setenv "HAVE_VALGRIND_TRUE" "")
+ (setenv "HAVE_VALGRIND_FALSE" "#")
+ #t)))))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gtk+-2" ,gtk+-2)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gnome-doc-utils" ,gnome-doc-utils)
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("json-glib" ,json-glib)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2)
+ ("vala" ,vala)))
+ (home-page "https://launchpad.net/libdbusmenu")
+ (synopsis "Library for passing menus over DBus")
+ (description "@code{libdbusmenu} passes a menu structure across DBus so
+that a program can create a menu simply without worrying about how it is
+displayed on the other side of the bus.")
+ (license (list license:gpl3 license:lgpl2.1 license:lgpl3))))