summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-08 00:40:37 -0500
committerLeo Famulari <leo@famulari.name>2017-03-08 03:52:03 -0500
commitda79e82b14b78dba7247cd39c370efd7887ed9fc (patch)
tree6882c612df5999f64a1513b14b036815d4ddbd5b /gnu/packages/gtk.scm
parent9a91b00fd08e652d158bd6bf96bdcb045f7c72cb (diff)
downloadpatches-da79e82b14b78dba7247cd39c370efd7887ed9fc.tar
patches-da79e82b14b78dba7247cd39c370efd7887ed9fc.tar.gz
gnu: gtk+: Build GTK+ with its own xorg-server package.
This will allow us to update xorg-server directly on the master branch. * gnu/packages/xorg.scm (xorg-server-1.19.2): New variable. * gnu/packages/gtk.scm (gtk+) [native-inputs]: Use xorg-server-1.19.2 instead of xorg-server. [arguments]: Add xorg-server-1.19.2 to #:disallowed-references.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 92f399ecb6..057c808597 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -689,9 +689,12 @@ application suites.")
("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)
- ("xorg-server" ,xorg-server)))
+ ;; By using a special xorg-server for GTK+'s tests, we reduce the impact
+ ;; of updating xorg-server directly on the master branch.
+ ("xorg-server" ,xorg-server-1.19.2)))
(arguments
- `(;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes
+ `(#:disallowed-references (,xorg-server-1.19.2)
+ ;; 47 MiB goes to "out" (24 of which is locale data!), and 26 MiB goes
;; to "doc".
#:configure-flags (list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")