summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-05 19:15:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-05 19:15:39 +0200
commitcf6db76d2af2f287f12928df160447ab4165b3e5 (patch)
tree49a1309c0e04c00090ab106f7ae3495a6da328c1 /gnu/packages/gtk.scm
parente65b2181e8b436278e3dd0b405602a400fbd0a75 (diff)
parenta6798218bea0d6b2df598042d1ced29f74bb4250 (diff)
downloadpatches-cf6db76d2af2f287f12928df160447ab4165b3e5.tar
patches-cf6db76d2af2f287f12928df160447ab4165b3e5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm58
1 files changed, 15 insertions, 43 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d65eb547ad..ccedec6398 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -774,54 +774,26 @@ application suites.")
(define-public guile-cairo
(package
(name "guile-cairo")
- (version "1.4.1")
+ (version "1.10.0")
(source (origin
(method url-fetch)
- (uri (string-append
- "http://download.gna.org/guile-cairo/guile-cairo-"
- version
- ".tar.gz"))
+ (uri (string-append "mirror://savannah/guile-cairo/guile-cairo-"
+ version ".tar.gz"))
(sha256
(base32
- "1f5nd9n46n6cwfl1byjml02q3y2hgn7nkx98km1czgwarxl7ws3x"))))
+ "0p6xrhf2k6n5dybn88050za7h90gnd7534n62l53vsca187pwgdf"))
+ (modules '((guix build utils)))
+ (snippet
+ (begin
+ '(begin
+ ;; Install Scheme files in …/guile/site/X.Y.
+ (substitute* (find-files "." "^Makefile\\.in$")
+ (("^(.*)dir = (.*)/guile/site(.*)" _ name prefix suffix)
+ (string-append name "dir = " prefix
+ "/guile/site/@GUILE_EFFECTIVE_VERSION@"
+ suffix)))
+ #t)))))
(build-system gnu-build-system)
- (arguments
- '(#:modules ((guix build utils)
- (guix build gnu-build-system)
- (ice-9 popen)
- (ice-9 rdelim))
-
- #:phases (modify-phases %standard-phases
- (add-before 'configure 'set-module-directory
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Install modules under $out/share/guile/site/2.0.
- (let ((out (assoc-ref outputs "out"))
- (effective
- (read-line
- (open-pipe* OPEN_READ "guile" "-c"
- "(display (effective-version))"))))
- (substitute* "Makefile.in"
- (("scmdir = ([[:graph:]]+).*" _ value)
- (string-append "scmdir = " value "/" effective "\n")))
- (substitute* "cairo/Makefile.in"
- (("moduledir = ([[:graph:]]+).*" _ value)
- (string-append "moduledir = "
- "$(prefix)/share/guile/site/"
- effective "/cairo\n'")))
- #t)))
- (add-after 'install 'install-missing-file
- (lambda* (#:key outputs #:allow-other-keys)
- ;; By default 'vector-types.scm' is not installed, so do
- ;; it here.
- (let ((out (assoc-ref outputs "out"))
- (effective
- (read-line
- (open-pipe* OPEN_READ "guile" "-c"
- "(display (effective-version))"))))
- (install-file "cairo/vector-types.scm"
- (string-append out "/share/guile/site/"
- effective "/cairo"))
- #t))))))
(inputs
`(("guile-lib" ,guile-lib)
("expat" ,expat)