summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-10 08:23:30 -0400
committerMarius Bakke <mbakke@fastmail.com>2017-05-14 17:30:08 +0200
commit982b35747854f7be35700572ec75e45881fa55e2 (patch)
tree683be65bb9d61ec0c459bd7e172383b4dff7a691 /gnu/packages/gtk.scm
parenteb6f315b044bd23c5207a36cdce43e197f8ff00f (diff)
downloadpatches-982b35747854f7be35700572ec75e45881fa55e2.tar
patches-982b35747854f7be35700572ec75e45881fa55e2.tar.gz
gnu: gtk+: Enable wayland backend.
* gnu/packages/gtk.scm (gtk+)[propagated-inputs]: Add libxkbcommon, mesa, wayland and wayland-protocols. [arguments]: Add "--enable-wayland-backend" and "--enable-x11-backend" to #:configure-flags.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 985056b95b..9732ee4ccd 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages docbook)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
@@ -673,8 +674,12 @@ application suites.")
("libxcursor" ,libxcursor)
("libxi" ,libxi)
("libxinerama" ,libxinerama)
+ ("libxkbcommon" ,libxkbcommon)
("libxdamage" ,libxdamage)
- ("pango" ,pango)))
+ ("mesa" ,mesa)
+ ("pango" ,pango)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
(inputs
`(("libxml2" ,libxml2)
;; XXX: colord depends on mozjs (through polkit), which fails on
@@ -700,7 +705,12 @@ application suites.")
;; to "doc".
#:configure-flags (list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))
+ "/share/gtk-doc/html")
+ ;; The header file <gdk/gdkwayland.h> is required
+ ;; by gnome-control-center
+ "--enable-wayland-backend"
+ ;; This is necessary to build both backends.
+ "--enable-x11-backend")
#:phases (modify-phases %standard-phases
(add-before 'configure 'pre-configure
(lambda _