summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-08 20:36:00 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-08 21:23:05 +0200
commit080edbe949c67f88e4ca002fc919f4ead8d814ae (patch)
tree03e71543a082631799adf38c285dce8538bc8bb2 /gnu/packages/gtk.scm
parent3572b3904feb4162855fba9f974cc58a236038ba (diff)
downloadpatches-080edbe949c67f88e4ca002fc919f4ead8d814ae.tar
patches-080edbe949c67f88e4ca002fc919f4ead8d814ae.tar.gz
gnu: gdk-pixbuf: Update to 2.40.0.
* gnu/packages/gtk.scm (gdk-pixbuf): Update to 2.40.0. [arguments]: Remove obsolete phase.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 34f9ca3844..3f6043fcac 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -460,7 +460,7 @@ highlighting and other features typical of a source code editor.")
(define-public gdk-pixbuf
(package
(name "gdk-pixbuf")
- (version "2.38.1")
+ (version "2.40.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -468,7 +468,7 @@ highlighting and other features typical of a source code editor.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0fmbjgjcyym3qg46f64qgl7icdm4ii77flyc1mhk244rp8vgi7zi"))))
+ "1rnlx9yfw970maxi2x6niaxmih5la11q1ilr7gzshz2kk585k0hm"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dinstalled_tests=false")
@@ -494,16 +494,7 @@ highlighting and other features typical of a source code editor.")
'((replace 'check
(lambda _
(invoke "meson" "test" "--timeout-multiplier" "5"))))
- '())
- (add-before 'configure 'aid-install-script
- (lambda* (#:key outputs #:allow-other-keys)
- ;; "build-aux/post-install.sh" invokes `gdk-pixbuf-query-loaders`
- ;; for updating loader.cache, but it's not on PATH. Make it use
- ;; the one we're installing. XXX: Won't work when cross-compiling.
- (substitute* "build-aux/post-install.sh"
- (("gdk-pixbuf-query-loaders" match)
- (string-append (assoc-ref outputs "out") "/bin/" match)))
- #t)))))
+ '()))))
(propagated-inputs
`(;; Required by gdk-pixbuf-2.0.pc
("glib" ,glib)