summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-22 10:23:59 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-22 10:44:03 +0800
commitb19d6805a95404750ac90f19d78e29c885daacff (patch)
tree3c59f99c41688cfc6d47a0da8a7c77e109bb70e1 /gnu/packages/gtk.scm
parent702513b51acfec33567477383778a3907a448481 (diff)
downloadpatches-b19d6805a95404750ac90f19d78e29c885daacff.tar
patches-b19d6805a95404750ac90f19d78e29c885daacff.tar.gz
Remove all the 'CC=gcc' hacks for 'g-ir-scanner'.
* gnu/packages/glib.scm (telepathy-glib)[arguments]: Remove. * gnu/packages/gtk.scm (at-spi2-core, gtk+-2): Remove #:make-flags. * gnu/packages/gnome.scm (libpeas, librsvg, vala, vte, json-glib, libxklavier, libsoup, libsecret, colord, geocode-glib, libgweather): Remove #:make-flags or the '(setenv "CC" "gcc")' phase.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 67838a3752..c9b3313280 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -353,8 +353,7 @@ in the GNOME project.")
(build-system gnu-build-system)
(outputs '("out" "doc"))
(arguments
- '(#:make-flags '("CC=gcc") ; for g-ir-scanner
- #:configure-flags
+ '(#:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))
@@ -450,8 +449,7 @@ is part of the GNOME accessibility project.")
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
(arguments
- `(#:make-flags '("CC=gcc")
- #:configure-flags
+ `(#:configure-flags
(list "--with-xinput=yes"
(string-append "--with-html-dir="
(assoc-ref %outputs "doc")