summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 16:40:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:39 +0200
commita20608a57a7944376b53bc68cfaef6c3229b2321 (patch)
tree4f190c55200e3e99e6d1da74e75593cb3b4920b8 /gnu/packages/gtk.scm
parentb81dd94a790636fea9ac59ad1c63d78420fad54a (diff)
downloadpatches-a20608a57a7944376b53bc68cfaef6c3229b2321.tar
patches-a20608a57a7944376b53bc68cfaef6c3229b2321.tar.gz
gnu: gtk-doc: Fix dblatex problem.
* gnu/packages/gtk.scm (gtk-doc)[arguments]: Add phase "set-HOME".
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d5b472049d..b2aa6ecff5 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Coypright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Coypright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
@@ -1285,8 +1285,13 @@ information.")
`(#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
- (add-before
- 'configure 'fix-docbook
+ (add-before 'build 'set-HOME
+ (lambda _
+ ;; FIXME: dblatex with texlive-union does not find the built
+ ;; metafonts, so it tries to generate them in HOME.
+ (setenv "HOME" "/tmp")
+ #t))
+ (add-before 'configure 'fix-docbook
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "configure"
;; The configure check is overzealous about making sure that