summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
commit839167ff9d74fc490b32f6a197591964f73b65e5 (patch)
treed193bfad7c9ef5597c5cd7d2ea25fd007d01f88a /gnu/packages/gstreamer.scm
parent27c1df05a866b639a61e16d48b3f2da8fa5eb767 (diff)
parent030c912616c8ee1595218e304460041bcb4f1ceb (diff)
downloadpatches-839167ff9d74fc490b32f6a197591964f73b65e5.tar
patches-839167ff9d74fc490b32f6a197591964f73b65e5.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 63d18fce5c..f556861857 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -167,7 +167,6 @@ This package provides the core library and elements.")
("orc" ,orc))) ;required by gstreamer-audio-1.0.pc
(inputs
`(("cdparanoia" ,cdparanoia)
- ("opus" ,opus)
("pango" ,pango)
("libogg" ,libogg)
("libtheora" ,libtheora)
@@ -176,7 +175,12 @@ This package provides the core library and elements.")
("zlib" ,zlib)
("libXext" ,libxext)
("libxv" ,libxv)
- ("alsa-lib" ,alsa-lib)))
+ ("alsa-lib" ,alsa-lib)
+ ;; XXX Don't build with opus on 32-bit systems:
+ ;; <https://bugs.gnu.org/32360>
+ ,@(if (target-64bit?)
+ `(("opus" ,opus))
+ '())))
(native-inputs
`(("pkg-config" ,pkg-config)
("glib:bin" ,glib "bin")