summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-11-03 22:00:04 +0800
committer宋文武 <iyzsong@gmail.com>2015-11-03 22:06:30 +0800
commit7bc36f8d96fb40a449c405a29ecdceb69a658132 (patch)
tree3876a48fa96e6c7678dc33051f27177931d5ddda /gnu/packages/gstreamer.scm
parent31e021f8767abb2c37e1c7a2e7aa6be276667bd3 (diff)
downloadpatches-7bc36f8d96fb40a449c405a29ecdceb69a658132.tar
patches-7bc36f8d96fb40a449c405a29ecdceb69a658132.tar.gz
gnu: gst-plugins-base: Update to 1.6.1.
* gnu/packages/gstreamer.scm (gst-plugins-base): Update to 1.6.1. [arguments]: Disable parallel tests.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 90061b2e94..619a63f934 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -130,7 +130,7 @@ This package provides the core library and elements.")
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
- (version "1.4.5")
+ (version "1.6.1")
(source
(origin
(method url-fetch)
@@ -138,7 +138,7 @@ This package provides the core library and elements.")
version ".tar.xz"))
(sha256
(base32
- "07ampnfa6p41s0lhia62l9h8bdx3c7vxvdz93pbx64m3wycq3gbp"))))
+ "18sbyjcp281zb3bsqji3pglsdsxi0s6ai7rx90sx8cpflkxdqcwm"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
@@ -161,7 +161,8 @@ This package provides the core library and elements.")
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)))
(arguments
- `(#:configure-flags
+ `(#:parallel-tests? #f ; 'pipelines/tcp' fails in parallel
+ #:configure-flags
(list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))
@@ -170,9 +171,7 @@ This package provides the core library and elements.")
'configure 'patch
(lambda _
(substitute* "tests/check/libs/pbutils.c"
- (("/bin/sh") (which "sh")))
- ;; for g-ir-scanner.
- (setenv "CC" "gcc"))
+ (("/bin/sh") (which "sh"))))
%standard-phases)))
(home-page "http://gstreamer.freedesktop.org/")
(synopsis