summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-14 00:09:10 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-14 23:03:05 +0800
commit04a20db2b302395d24ecfd41c270897e68f21345 (patch)
tree64e53a8584ee553c359d75004016c2151cee6bed /gnu/packages/gstreamer.scm
parentd5f01e48e0810147c4f304a0e5c661e5a61e08ff (diff)
downloadpatches-04a20db2b302395d24ecfd41c270897e68f21345.tar
patches-04a20db2b302395d24ecfd41c270897e68f21345.tar.gz
gnu: gst-libav: Use system ffmpeg instead of bundled libav.
* gnu/packages/gstreamer.scm (gst-libav)[arguments]: Remove #:phases. Add #:configure-flags. [native-inputs]: Remove yasm. [inputs]: Add ffmpeg.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 9758806cc5..e07bbec510 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages perl)
#:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages video)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xiph)
#:use-module (gnu packages pkg-config)
@@ -262,19 +263,13 @@ developers consider to have good quality code and correct functionality.")
"1g7vg9amh3cc3nmc415h6g2rqxqi4wgwqi08hxfbpwq48ri64p30"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before configure patch-/bin/sh
- (lambda _
- (substitute* "gst-libs/ext/libav/configure"
- (("#! /bin/sh")
- (string-append "#! "(which "sh")))))))))
+ '(#:configure-flags '("--with-system-libav")))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python" ,python)
- ("yasm" ,yasm)))
+ ("python" ,python)))
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
+ ("ffmpeg" ,ffmpeg)
("orc" ,orc)
("zlib" ,zlib)))
(home-page "http://gstreamer.freedesktop.org/")