summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-22 16:22:00 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-22 16:22:00 +0200
commit22885fb845c67cc48a426a989e2a45de18a8e888 (patch)
treef50bfa4140a6026b163fa3b9dad5855bca7f3dc5 /gnu/packages/gstreamer.scm
parent93be8dc4c93dec03b68fcbb8a8955f9b4b562ba6 (diff)
downloadpatches-22885fb845c67cc48a426a989e2a45de18a8e888.tar
patches-22885fb845c67cc48a426a989e2a45de18a8e888.tar.gz
gnu: Add gstreamer.
* gnu/packages/gstreamer.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add module.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
new file mode 100644
index 0000000000..01448563a9
--- /dev/null
+++ b/gnu/packages/gstreamer.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gstreamer)
+ #:use-module ((guix licenses) #:select (lgpl2.0+))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages flex)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python))
+
+(define-public gstreamer
+ (package
+ (name "gstreamer")
+ (version "1.0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0c0irk85jd2cihm5pmf4zxhlpg08qpxjcqv1l9qn2n3h2gsaj2lf"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("glib" ,glib)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "http://gstreamer.freedesktop.org/")
+ (synopsis
+ "Multimedia library")
+ (description
+ "GStreamer is a library for constructing graphs of media-handling
+components. The applications it supports range from simple Ogg/Vorbis
+playback, audio/video streaming to complex audio (mixing) and video
+(non-linear editing) processing.
+
+Applications can take advantage of advances in codec and filter technology
+transparently. Developers can add new codecs and filters by writing a
+simple plugin with a clean, generic interface.
+
+This package provides the core library and elements.")
+ (license lgpl2.0+)))