summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2017-11-06 09:30:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-07 21:03:15 +0100
commit2b295f5a2fc221020dd4ae8e090bd19a7e017872 (patch)
tree4febe818c0833a21156495d2044aada62c288b28 /gnu/packages/graphviz.scm
parent38ad27da807077c953d19ab655ce57c124437b0c (diff)
downloadpatches-2b295f5a2fc221020dd4ae8e090bd19a7e017872.tar
patches-2b295f5a2fc221020dd4ae8e090bd19a7e017872.tar.gz
gnu: Add python-pydot.
* gnu/packages/graphviz.scm (python-pydot, python2-pydot): New variables. Modified-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index c71fb74cfb..2fefb41c0a 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,6 +42,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages gd)
#:use-module (gnu packages swig)
+ #:use-module (gnu packages python)
#:use-module ((guix licenses) #:prefix license:))
(define-public graphviz
@@ -211,3 +213,29 @@ visualization tool suite.")
an intermediate format,and @code{gtk} and @code{cairo} for rendering. Xdot can
be used either as a standalone application, or as a python library.")
(license license:lgpl3+)))
+
+(define-public python-pydot
+ (package
+ (name "python-pydot")
+ (version "1.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pydot" version))
+ (sha256
+ (base32
+ "00imlz0033dygb9gdag1xr0cybn33gk5jsdi9ffbszzr97rd7dgd"))))
+ (build-system python-build-system)
+ ;; FIXME: No tests in PyPi release tarball.
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("python-pyparsing" ,python-pyparsing)))
+ (home-page "https://github.com/erocarrera/pydot")
+ (synopsis "Python interface to Graphviz's DOT language")
+ (description
+ "Pydot provides an interface to create, handle, modify and process
+graphs in Graphviz's DOT language, written in pure Python.")
+ (license license:expat)))
+
+(define-public python2-pydot
+ (package-with-python2 python-pydot))