summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-05 16:09:27 -0600
committerLudovic Courtès <ludo@gnu.org>2016-01-12 21:07:53 +0100
commitc91d3fb7f4f754b56b540d8556d6a3ce6085ef37 (patch)
tree89c7d1ff32dcf730de4c26033b8ea1786395129e /gnu/packages/graphics.scm
parent3abe8136fddf5bed75219bcb8a552004f078560a (diff)
downloadpatches-c91d3fb7f4f754b56b540d8556d6a3ce6085ef37.tar
patches-c91d3fb7f4f754b56b540d8556d6a3ce6085ef37.tar.gz
gnu: boost: Update to 1.60.0.
* gnu/packages/boost.scm (boost): Update to 1.60.0. [source]: Remove patch. * gnu/packages/patches/boost-mips-avoid-m32.patch: Delete patch * gnu-system.am (dist_patch_DATA): Remove patch. Also fix dependent packages: * gnu/packages/patches/csound-header-ordering.patch: New patch. * gnu/packages/audio.scm (csound)[source]: Use it. [arguments]: Add 'set-flags phase. * gnu/packages/patches/libcmis-fix-test-onedrive.patch: New patch. * gnu/packages/libreoffice.scm (libcmis)[source]: Use it. (libreoffice)[arguments]: Add LDFLAGS to #:configure-flags. (librevenge)[inputs]: Move boost from here... [propogated-inputs]: to here. [arguments]: Add LDFLAGS to #:configure-flags. * gnu/packages/patches/openimageio-boost-1.60.patch: New patch. * gnu/packages/graphics.scm (openimageio): Use it. * gnu-system.am (dist_patch_DATA): Add patches.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 4e15b814c8..560febe958 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -143,7 +143,8 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0mn7cz19mn8dcrhkq15h25gl20ammr1wz0j2j3c2vxs6ph7zn8jy"))))
+ "0mn7cz19mn8dcrhkq15h25gl20ammr1wz0j2j3c2vxs6ph7zn8jy"))
+ (patches (list (search-patch "openimageio-boost-1.60.patch")))))
(build-system cmake-build-system)
;; FIXME: To run all tests successfully, test image sets from multiple
;; third party sources have to be present. For details see