summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-05 09:40:08 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-05 22:45:41 +0200
commit79f912c7106131f4179c727583d33500271361cd (patch)
treedea65ea2e8003549efc20a92e3f4787e2ac85edb /gnu/packages/graphics.scm
parentb28187cd0ca75a17a12dce9bfb5855d8fbf61eb3 (diff)
downloadpatches-79f912c7106131f4179c727583d33500271361cd.tar
patches-79f912c7106131f4179c727583d33500271361cd.tar.gz
Revert "gnu: openexr: Add IlmBase include sub-directory to 'OpenEXR.pc'."
This reverts commit 01fe019166fe8a925b3bf3b489792b52b1b6ca7a, which was unneeded because IlmBase is already listed as 'Requires' in 'OpenEXR.pc'.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm16
1 files changed, 1 insertions, 15 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 79c7772af9..a502f246ff 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
@@ -256,20 +256,6 @@ exception-handling library.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'set-ilmbase-directory-in-pc-file
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Add '-I ILMBASE/include/OpenEXR' to 'OpenEXR.pc' since some of
- ;; the headers of OpenEXR expect IlmBase headers to live in the
- ;; same directory. Unfortunately this doesn't help much because
- ;; 'FindOpenEXR.cmake' doesn't read 'OpenEXR.pc'...
- (let ((ilmbase (assoc-ref inputs "ilmbase")))
- (substitute* "OpenEXR.pc.in"
- (("^Cflags: (.*)$" _ cflags)
- (string-append "Cflags: "
- " -I" ilmbase "/include"
- " -I" ilmbase "/include/OpenEXR "
- cflags "\n")))
- #t)))
(add-after 'unpack 'disable-broken-test
;; This test fails on i686. Upstream developers suggest that
;; this test is broken on i686 and can be safely disabled: