summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-08-15 18:20:17 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-09-17 11:04:14 +1000
commitf76d56d2868e4339915c42d3d9b93c1cb38e7e92 (patch)
tree9e4bfed2a0f29c9903eb581737bdc44c3d4a4bf0 /gnu/packages/graphics.scm
parent963926bc78cf79fab2fea26aca6c760c91ecf4f2 (diff)
downloadpatches-f76d56d2868e4339915c42d3d9b93c1cb38e7e92.tar
patches-f76d56d2868e4339915c42d3d9b93c1cb38e7e92.tar.gz
gnu: Add python-pastel.
* gnu/packages/graphics.scm (python-pastel): New variable.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f84cc27836..e9dc6d560d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (guix packages)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
@@ -654,3 +656,33 @@ and understanding different BRDFs (and other component functions).")
It supports sub-pixel resolutions and anti-aliasing. It is also library for
rendering SVG graphics.")
(license license:gpl2+)))
+
+(define-public python-pastel
+ (package
+ (name "python-pastel")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pastel" version))
+ (sha256
+ (base32
+ "1hqbm934n5yjwn31aq8h7shrr0rcy326wrqfc856vyn0gr0sy21i"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/sdispater/pastel")
+ (synopsis "Library to colorize strings in your terminal")
+ (description "Pastel is a simple library to help you colorize strings in
+your terminal. It comes bundled with predefined styles:
+@enumerate
+@item info: green
+@item comment: yellow
+@item question: black on cyan
+@item error: white on red
+@end enumerate
+")
+ (license license:expat)))
+
+(define-public python2-pastel
+ (package-with-python2 python-pastel))