summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-03-28 11:07:40 +0100
committerEfraim Flashner <efraim@flashner.co.il>2019-03-28 12:14:22 +0200
commit1aa662b3094172c9f34a220d15c6ba53b9280b79 (patch)
treed8954eb5502d9a2d4721f33c2785872db31b534f /gnu/packages/graphics.scm
parentd5640c587f141ff60127848dc95528ca1a4f1b14 (diff)
downloadpatches-1aa662b3094172c9f34a220d15c6ba53b9280b79.tar
patches-1aa662b3094172c9f34a220d15c6ba53b9280b79.tar.gz
gnu: ogre: Don't use unstable tarball.
* gnu/packages/graphics.scm (ogre)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index e4a6ee8476..25c9e0b476 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -354,13 +354,14 @@ exception-handling library.")
(version "1.10.11")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/OGRECave/" name
- "/archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OGRECave/ogre.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "13bdh9v4026qf8w8rbfln2rmwf0rby1a8fz55zpdvpy105i6cbpz"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "072rzw9mxymbiypgkrbkk9h10rgly6gczik4dlmssk6xkpqckaqr"))))
(build-system cmake-build-system)
(arguments
'(#:phases