summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
committerMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
commit647888845c0d7b9ea1b51a3e3492d4d2382f4468 (patch)
treebe34c5ec88db452c63253dc4a15f9f4cf199b1e6 /gnu/packages/graphics.scm
parentfe15613cdf8623574ce64c05416dd3fab41eef86 (diff)
parentc657716ede8932da356635802534aa13205a6ecd (diff)
downloadpatches-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar
patches-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 61cd4ef5b4..58a6f7bc13 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -424,25 +424,24 @@ visual effects work for film.")
(file-name (string-append name "-" version ".zip"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;; No test target available.
+ `(#:tests? #f ; no test target available
+ ;; Without this flag, 'rd' will be added to the name of the
+ ;; library binaries and break linking with other programs.
+ #:build-type "Release"
#:configure-flags
(list (string-append "-DCMAKE_INSTALL_RPATH="
(assoc-ref %outputs "out") "/lib:"
- (assoc-ref %outputs "out") "/lib64")
- ;; We need to set this flag or otherwise 'rd' will be added
- ;; to the name of the library binaries and break linking
- ;; with other programs.
- "-DCMAKE_BUILD_TYPE=Release")))
+ (assoc-ref %outputs "out") "/lib64"))))
(native-inputs
`(("unzip" ,unzip)))
(inputs
- `(("giflib", giflib)
- ("jasper", jasper)
- ("librsvg", librsvg)
- ("pth", pth)
- ("qtbase", qtbase)
- ("ffmpeg", ffmpeg)
- ("mesa", mesa)))
+ `(("giflib" ,giflib)
+ ("jasper" ,jasper)
+ ("librsvg" ,librsvg)
+ ("pth" ,pth)
+ ("qtbase" ,qtbase)
+ ("ffmpeg" ,ffmpeg)
+ ("mesa" ,mesa)))
(synopsis "High performance real-time graphics toolkit")
(description
"The OpenSceneGraph is a high performance 3D graphics toolkit