aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-01 00:02:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-01 00:02:39 +0200
commit571fb008a576378883c053be186d2c620290ea39 (patch)
tree5279a2c2772a9b76299a48d697d568f208a89722 /gnu/packages/graphics.scm
parent7c86fdda7ceed11377b0e17b47c91598be59be52 (diff)
parentf125c5a5ea03d53749f45d310694b79241d5888d (diff)
downloadpatches-571fb008a576378883c053be186d2c620290ea39.tar
patches-571fb008a576378883c053be186d2c620290ea39.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm28
1 files changed, 9 insertions, 19 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 11158bdfd1..25c9e0b476 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -354,33 +354,23 @@ exception-handling library.")
(version "1.10.11")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/OGRECave/" name
- "/archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OGRECave/ogre.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "13bdh9v4026qf8w8rbfln2rmwf0rby1a8fz55zpdvpy105i6cbpz"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "072rzw9mxymbiypgkrbkk9h10rgly6gczik4dlmssk6xkpqckaqr"))))
(build-system cmake-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-before 'configure 'pre-configure
- (lambda _
- ;; It expects googletest source to be downloaded and
- ;; be in a specific place.
- (substitute* "Tests/CMakeLists.txt"
- (("URL(.*)$" _ suffix)
- (string-append "URL " suffix
- "\t\tURL_HASH "
- "MD5=16877098823401d1bf2ed7891d7dce36\n")))
- #t))
- (add-before 'build 'pre-build
(lambda* (#:key inputs #:allow-other-keys)
- (copy-file (assoc-ref inputs "googletest-source")
- (string-append (getcwd)
- "/Tests/googletest-prefix/src/"
- "release-1.8.0.tar.gz"))
+ (substitute* "Tests/CMakeLists.txt"
+ (("URL(.*)$")
+ (string-append "URL " (assoc-ref inputs "googletest-source"))))
#t)))
#:configure-flags
(list "-DOGRE_BUILD_TESTS=TRUE"