summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-16 11:28:03 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:02 -0400
commit2da5275f818f56587fca5527d30919442eb74b4b (patch)
tree2bd85c1c92252ed7d87595cb6b8d949f409535b0 /gnu/packages/golang.scm
parent6d766bec446690fec6a15eaf48cd223a8c2426b3 (diff)
downloadpatches-2da5275f818f56587fca5527d30919442eb74b4b.tar
patches-2da5275f818f56587fca5527d30919442eb74b4b.tar.gz
gnu: Move go-github-com-pkg-errors to the Golang package module.
* gnu/packages/syncthing.scm (go-github-com-pkg-errors): Move ... * gnu/packages/golang.scm (go-github-com-pkg-errors): ... here.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 73f740299b..ed9ccd2d14 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3584,3 +3584,25 @@ implementation of generics.")
network protocol.")
(home-page "https://github.com/lucas-clemente/quic-go")
(license license:expat)))
+
+(define-public go-github-com-pkg-errors
+ (package
+ (name "go-github-com-pkg-errors")
+ (version "0.8.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pkg/errors.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g5qcb4d4fd96midz0zdk8b9kz8xkzwfa8kr1cliqbg8sxsy5vd1"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/pkg/errors"))
+ (synopsis "Go error handling primitives")
+ (description "This package provides @code{error}, which offers simple
+error handling primitives in Go.")
+ (home-page "https://github.com/pkg/errors")
+ (license license:bsd-2)))