summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-13 16:15:46 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:29 -0400
commit24e3520dd0260eb81a90bc6bd007cbf17c381bb0 (patch)
tree6a92e15654b73f8250c505b530560b271544ae10 /gnu/packages/golang.scm
parentb3f0f8a62e7f7f34c85badee7f8dc158017382f0 (diff)
downloadpatches-24e3520dd0260eb81a90bc6bd007cbf17c381bb0.tar
patches-24e3520dd0260eb81a90bc6bd007cbf17c381bb0.tar.gz
gnu: go-github-com-mattn-go-isatty: Use upstream version string.
* gnu/packages/golang.scm (go-github-com-mattn-go-isatty): Use upstream version.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 348527f893..190d4c802f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1855,30 +1855,28 @@ values.")
(license license:asl2.0))))
(define-public go-github-com-mattn-go-isatty
- (let ((commit "6ca4dbf54d38eea1a992b3c722a76a5d1c4cb25c")
- (revision "0"))
- (package
- (name "go-github-com-mattn-go-isatty")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/go-isatty")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0zs92j2cqaw9j8qx1sdxpv3ap0rgbs0vrvi72m40mg8aa36gd39w"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/mattn/go-isatty"))
- (home-page "https://github.com/mattn/go-isatty")
- (synopsis "Provide @code{isatty} for Golang")
- (description "This package provides @code{isatty}, a Go module that can
+ (package
+ (name "go-github-com-mattn-go-isatty")
+ (version "0.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattn/go-isatty")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zs92j2cqaw9j8qx1sdxpv3ap0rgbs0vrvi72m40mg8aa36gd39w"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mattn/go-isatty"))
+ (home-page "https://github.com/mattn/go-isatty")
+ (synopsis "Provide @code{isatty} for Golang")
+ (description "This package provides @code{isatty}, a Go module that can
tell you whether a file descriptor points to a terminal and the type of the
terminal.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-mattn-go-colorable
(let ((commit "efa589957cd060542a26d2dd7832fd6a6c6c3ade")