summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-26 18:34:48 -0400
committerLeo Famulari <leo@famulari.name>2019-04-02 13:07:03 -0400
commit4a136536e831e6299200174af287236ec8e5b7f3 (patch)
tree005d629e405e04011a8374109b75d5f2c2859fc2 /gnu/packages/golang.scm
parent1ccc0f807d3f22fa9ade1c607c112e04df833a72 (diff)
downloadpatches-4a136536e831e6299200174af287236ec8e5b7f3.tar
patches-4a136536e831e6299200174af287236ec8e5b7f3.tar.gz
gnu: Add go-golang-org-x-sys-cpu.
* gnu/packages/golang.scm (go-golang-org-x-sys-cpu): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5de6b9699f..ac71115e6d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1272,6 +1272,17 @@ for low-level interaction with the operating system.")
(home-page "https://go.googlesource.com/sys")
(license license:bsd-3))))
+(define-public go-golang-org-x-sys-cpu
+ (package
+ (inherit go-golang-org-x-sys-unix)
+ (name "go-golang-org-x-sys-cpu")
+ (arguments
+ '(#:import-path "golang.org/x/sys/cpu"
+ #:unpack-path "golang.org/x/sys"))
+ (synopsis "CPU feature detection")
+ (description "Thi spackage provides @code{cpu}, which offers tools for CPU
+feature detection in Go.")))
+
(define-public go-golang-org-x-text-transform
(let ((commit "e19ae1496984b1c655b8044a65c0300a3c878dd3")
(revision "1"))