summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-23 22:57:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-23 22:57:16 +0100
commitdb0e9fe42c419c8c8010dbad6080ed66028c03ec (patch)
tree514a0d8fe5465db9a950ac20579e5d3e37bc385b /gnu/packages/golang.scm
parent43190ac64c5181841d68beade4d19e792f4f38a2 (diff)
parent82a2bd3a4ee09c04b51b948f1e952402d6a26f88 (diff)
downloadpatches-db0e9fe42c419c8c8010dbad6080ed66028c03ec.tar
patches-db0e9fe42c419c8c8010dbad6080ed66028c03ec.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f94251abaf..a6b5f2a4cf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -220,7 +220,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(package
(inherit go-1.4)
(name "go")
- (version "1.12.13")
+ (version "1.12.15")
(source
(origin
(method url-fetch)
@@ -228,7 +228,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
name version ".src.tar.gz"))
(sha256
(base32
- "19zmrhydd52vhdnzlhxqklzg1mnav434dcgw9wl4iajbvfwd70sk"))))
+ "1hw4xjywcl883dnvfbb92w85sy8n231fdri4aynj8xajgr0p9fla"))))
(arguments
(substitute-keyword-arguments (package-arguments go-1.4)
((#:phases phases)
@@ -266,9 +266,6 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(("/bin/pwd") (which "pwd"))
(("/bin/sh") (which "sh")))
- (substitute* "cmd/vendor/golang.org/x/sys/unix/syscall_unix_test.go"
- (("/usr/bin") "/tmp"))
-
;; Add libgcc to runpath
(substitute* "cmd/link/internal/ld/lib.go"
(("!rpath.set") "true"))