summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-10-28 13:20:52 -0400
committerLeo Famulari <leo@famulari.name>2019-10-29 11:03:11 -0400
commitb98b3674ee1556db6c5f62fc377eebceb14ae5ad (patch)
treea90098fafbe6fa5b412a169ce4792de507364bd4 /gnu/packages/golang.scm
parent4428532012637b39d9f5dabe8aea62a27a98341a (diff)
downloadpatches-b98b3674ee1556db6c5f62fc377eebceb14ae5ad.tar
patches-b98b3674ee1556db6c5f62fc377eebceb14ae5ad.tar.gz
gnu: Remove Go 1.11.
This version of Go is no longer supported upstream. * gnu/packages/golang.scm (go-1.11): Remove variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm181
1 files changed, 0 insertions, 181 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e17d19c8fb..4d5de2f89d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -216,187 +216,6 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(supported-systems '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux"))
(license license:bsd-3)))
-(define-public go-1.11
- (package
- (inherit go-1.4)
- (name "go")
- (version "1.11.12")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://storage.googleapis.com/golang/"
- name version ".src.tar.gz"))
- (sha256
- (base32
- "09k9zmq7hhgg0bf1y7rwa0kn7q1vkkr94cmg2iv9lq3najh5nykd"))))
- (arguments
- (substitute-keyword-arguments (package-arguments go-1.4)
- ((#:phases phases)
- `(modify-phases ,phases
- (replace 'prebuild
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((gcclib (string-append (assoc-ref inputs "gcc:lib") "/lib"))
- (ld (string-append (assoc-ref inputs "libc") "/lib"))
- (loader (car (find-files ld "^ld-linux.+")))
- (net-base (assoc-ref inputs "net-base"))
- (tzdata-path
- (string-append (assoc-ref inputs "tzdata") "/share/zoneinfo"))
- (output (assoc-ref outputs "out")))
-
- (for-each delete-file
- ;; Removing net/ tests, which fail when attempting to access
- ;; network resources not present in the build container.
- '("net/listen_test.go"
- "net/parse_test.go"
- "net/cgo_unix_test.go"
- ;; A side effect of these test scripts is testing
- ;; cgo. Attempts at using cgo flags and
- ;; directives with these scripts as specified
- ;; here (https://golang.org/cmd/cgo/) have not
- ;; worked. The tests continue to state that they
- ;; can not find crt1.o despite being present.
- "cmd/go/testdata/script/list_compiled_imports.txt"
- "cmd/go/testdata/script/mod_case_cgo.txt"
- ;; https://github.com/golang/go/issues/24884
- "os/user/user_test.go"))
-
- (substitute* "os/os_test.go"
- (("/usr/bin") (getcwd))
- (("/bin/pwd") (which "pwd"))
- (("/bin/sh") (which "sh")))
-
- (substitute* "cmd/vendor/golang.org/x/sys/unix/syscall_unix_test.go"
- (("/usr/bin") "/tmp"))
-
- ;; Add libgcc to runpath
- (substitute* "cmd/link/internal/ld/lib.go"
- (("!rpath.set") "true"))
- (substitute* "cmd/go/internal/work/gccgo.go"
- (("cgoldflags := \\[\\]string\\{\\}")
- (string-append "cgoldflags := []string{"
- "\"-rpath=" gcclib "\""
- "}"))
- (("\"-lgcc_s\", ")
- (string-append
- "\"-Wl,-rpath=" gcclib "\", \"-lgcc_s\", ")))
- (substitute* "cmd/go/internal/work/gc.go"
- (("ldflags = setextld\\(ldflags, compiler\\)")
- (string-append
- "ldflags = setextld(ldflags, compiler)\n"
- "ldflags = append(ldflags, \"-r\")\n"
- "ldflags = append(ldflags, \"" gcclib "\")\n")))
-
- ;; Disable failing tests: these tests attempt to access
- ;; commands or network resources which are neither available
- ;; nor necessary for the build to succeed.
- (for-each
- (match-lambda
- ((file regex)
- (substitute* file
- ((regex all before test_name)
- (string-append before "Disabled" test_name)))))
- '(("net/net_test.go" "(.+)(TestShutdownUnix.+)")
- ("net/dial_test.go" "(.+)(TestDialTimeout.+)")
- ("os/os_test.go" "(.+)(TestHostname.+)")
- ("time/format_test.go" "(.+)(TestParseInSydney.+)")
- ("time/format_test.go" "(.+)(TestParseInLocation.+)")
- ("os/exec/exec_test.go" "(.+)(TestEcho.+)")
- ("os/exec/exec_test.go" "(.+)(TestCommandRelativeName.+)")
- ("os/exec/exec_test.go" "(.+)(TestCatStdin.+)")
- ("os/exec/exec_test.go" "(.+)(TestCatGoodAndBadFile.+)")
- ("os/exec/exec_test.go" "(.+)(TestExitStatus.+)")
- ("os/exec/exec_test.go" "(.+)(TestPipes.+)")
- ("os/exec/exec_test.go" "(.+)(TestStdinClose.+)")
- ("os/exec/exec_test.go" "(.+)(TestIgnorePipeErrorOnSuccess.+)")
- ("syscall/syscall_unix_test.go" "(.+)(TestPassFD\\(.+)")
- ("os/exec/exec_test.go" "(.+)(TestExtraFiles/areturn.+)")
- ("cmd/go/go_test.go" "(.+)(TestCoverageWithCgo.+)")
- ("cmd/go/go_test.go" "(.+)(TestTwoPkgConfigs.+)")
- ("os/exec/exec_test.go" "(.+)(TestOutputStderrCapture.+)")
- ("os/exec/exec_test.go" "(.+)(TestExtraFiles.+)")
- ("os/exec/exec_test.go" "(.+)(TestExtraFilesRace.+)")
- ("net/lookup_test.go" "(.+)(TestLookupPort.+)")
- ("syscall/exec_linux_test.go"
- "(.+)(TestCloneNEWUSERAndRemapNoRootDisableSetgroups.+)")))
-
- ;; fix shebang for testar script
- ;; note the target script is generated at build time.
- (substitute* "../misc/cgo/testcarchive/carchive_test.go"
- (("#!/usr/bin/env") (string-append "#!" (which "env"))))
-
- (substitute* "net/lookup_unix.go"
- (("/etc/protocols") (string-append net-base "/etc/protocols")))
- (substitute* "net/port_unix.go"
- (("/etc/services") (string-append net-base "/etc/services")))
- (substitute* "time/zoneinfo_unix.go"
- (("/usr/share/zoneinfo/") tzdata-path))
- (substitute* (find-files "cmd" "\\.go")
- (("/lib(64)?/ld-linux.*\\.so\\.[0-9]") loader))
- #t)))
- (add-before 'build 'set-bootstrap-variables
- (lambda* (#:key outputs inputs #:allow-other-keys)
- ;; Tell the build system where to find the bootstrap Go.
- (let ((go (assoc-ref inputs "go")))
- (setenv "GOROOT_BOOTSTRAP" go)
- (setenv "GOGC" "400")
- #t)))
- (replace 'build
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; FIXME: Some of the .a files are not bit-reproducible.
- (let* ((output (assoc-ref outputs "out")))
- (setenv "CC" (which "gcc"))
- (setenv "GOOS" "linux")
- (setenv "GOROOT" (dirname (getcwd)))
- (setenv "GOROOT_FINAL" output)
- (setenv "CGO_ENABLED" "1")
- (invoke "sh" "all.bash"))))
-
- (replace 'install
- ;; TODO: Most of this could be factorized with Go 1.4.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((output (assoc-ref outputs "out"))
- (doc_out (assoc-ref outputs "doc"))
- (docs (string-append doc_out "/share/doc/" ,name "-" ,version))
- (src (string-append
- (assoc-ref outputs "tests") "/share/" ,name "-" ,version)))
- (delete-file-recursively "../pkg/bootstrap")
- ;; Prevent installation of the build cache, which contains
- ;; store references to most of the tools used to build Go and
- ;; would unnecessarily increase the size of Go's closure if it
- ;; was installed.
- (delete-file-recursively "../pkg/obj")
-
- (mkdir-p src)
- (copy-recursively "../test" (string-append src "/test"))
- (delete-file-recursively "../test")
- (mkdir-p docs)
- (copy-recursively "../api" (string-append docs "/api"))
- (delete-file-recursively "../api")
- (copy-recursively "../doc" (string-append docs "/doc"))
- (delete-file-recursively "../doc")
-
- (for-each
- (lambda (file)
- (let* ((filein (string-append "../" file))
- (fileout (string-append docs "/" file)))
- (copy-file filein fileout)
- (delete-file filein)))
- ;; Note the slightly different file names compared to 1.4.
- '("README.md" "CONTRIBUTORS" "AUTHORS" "PATENTS"
- "LICENSE" "VERSION" "CONTRIBUTING.md" "robots.txt"))
-
- (copy-recursively "../" output)
- #t)))))))
- (native-inputs
- `(("go" ,go-1.4)
- ,@(match (%current-system)
- ((or "armhf-linux" "aarch64-linux")
- `(("gold" ,binutils-gold)))
- (_ `()))
- ,@(package-native-inputs go-1.4)))
- (supported-systems %supported-systems)))
-
-
(define-public go-1.12
(package
(inherit go-1.4)