summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-09-06 20:46:00 -0400
committerMark H Weaver <mhw@netris.org>2019-09-06 20:46:00 -0400
commit65542a8852759f35e19959149ac92297c8b54be5 (patch)
treebc8f398c7b10a4725b20aa59ab1452d30f358ea3 /gnu/packages/golang.scm
parentbc60349b5bc58a0b803df5adce1de6db82453744 (diff)
parentf66aee3d0d2f573187ed5d44ae7c13d73cd4097a (diff)
downloadpatches-65542a8852759f35e19959149ac92297c8b54be5.tar
patches-65542a8852759f35e19959149ac92297c8b54be5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm66
1 files changed, 44 insertions, 22 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 20f5462528..b12fc4b4bd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3119,30 +3119,28 @@ as conversion to and from @command{net.Addr}.")
(license license:expat))))
(define-public go-github-com-urfave-cli
- (let ((commit "693af58b4d51b8fcc7f9d89576da170765980581")
- (revision "0"))
- (package
- (name "go-github-com-urfave-cli")
- (version (git-version "1.20.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/urfave/cli.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1krq752xgy658an1696vf4dc2zmp541clwjinhn11394sx2qksh6"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/urfave/cli"))
- (home-page "https://github.com/urfave/cli")
- (synopsis "Simple, fast, and fun package for building command line apps in Go")
- (description "@command{cli} is a simple, fast, and fun package for
+ (package
+ (name "go-github-com-urfave-cli")
+ (version "1.21.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/urfave/cli.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "104jldhxn6d97l5vsbsl0q8hgy1bxrahbr6dbfqrlppva51jmydd"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/urfave/cli"))
+ (home-page "https://github.com/urfave/cli")
+ (synopsis "Simple, fast, and fun package for building command line apps in Go")
+ (description "@command{cli} is a simple, fast, and fun package for
building command line apps in Go. The goal is to enable developers to write
fast and distributable command line applications in an expressive way.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-whyrusleeping-json-filter
(let ((commit "ff25329a9528f01c5175414f16cc0a6a162a5b8b")
@@ -3660,3 +3658,27 @@ and aid debugging.")
(description "This package provides a cron library for Go. It implements
a cron spec parser and job runner.")
(license license:expat)))
+
+(define-public go-github-com-shirou-gopsutil
+ (let ((commit "47ef3260b6bf6ead847e7c8fc4101b33c365e399")
+ (revision "0"))
+ (package
+ (name "go-github-com-shirou-gopsutil")
+ (version (git-version "v2.19.7" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shirou/gopsutil")
+ (commit commit))) ; XXX
+ (sha256
+ (base32
+ "0x1g4r32q4201nr2b754xnrrndmwsrhfr7zg37spya86qrmijnws"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/shirou/gopsutil"))
+ (synopsis "Process and system monitoring in Go")
+ (description "This package provides a library for retrieving information
+on running processes and system utilization (CPU, memory, disks, network,
+sensors).")
+ (home-page "https://github.com/shirou/gopsutil")
+ (license license:bsd-3))))