summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-17 14:19:38 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:04 -0400
commitc17e69b3aa4012a1f9f008daecf1cdd7539dd521 (patch)
tree9703e3077e09e739e2e5606bb33dbd4ac629af37 /gnu/packages/golang.scm
parent8629d8eda7bdd6cd6d353168af408e335e85d7d9 (diff)
downloadpatches-c17e69b3aa4012a1f9f008daecf1cdd7539dd521.tar
patches-c17e69b3aa4012a1f9f008daecf1cdd7539dd521.tar.gz
gnu: go-gopkg-in-yaml-v2: Update to 2.2.2.
* gnu/packages/golang.scm (go-gopkg-in-yaml-v2): Update to 2.2.2.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm48
1 files changed, 23 insertions, 25 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 02a7fd15d9..5b7814cb75 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1956,32 +1956,30 @@ which satisfies the cron expression.")
(license license:asl2.0))))
(define-public go-gopkg-in-yaml-v2
- (let ((commit "14227de293ca979cf205cd88769fe71ed96a97e2")
- (revision "0"))
- (package
- (name "go-gopkg-in-yaml-v2")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gopkg.in/yaml.v2.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "038hnrjcnjygyi3qidfrkpkakis82qg381sr495d2s40g2dwlzah"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "gopkg.in/yaml.v2"))
- (native-inputs
- `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
- (home-page "https://gopkg.in/yaml.v2")
- (synopsis "YAML reader and writer for the Go language")
- (description
- "This package provides a Go library for encode and decode YAML
+ (package
+ (name "go-gopkg-in-yaml-v2")
+ (version "2.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/yaml.v2.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01wj12jzsdqlnidpyjssmj0r4yavlqy7dwrg7adqd8dicjc4ncsa"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/yaml.v2"))
+ (native-inputs
+ `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
+ (home-page "https://gopkg.in/yaml.v2")
+ (synopsis "YAML reader and writer for the Go language")
+ (description
+ "This package provides a Go library for encode and decode YAML
values.")
- (license license:asl2.0))))
+ (license license:asl2.0)))
(define-public go-github-com-mattn-go-isatty
(package