summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-25 20:42:49 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-07-29 16:08:18 +0200
commit06c2d0e6c1f8c6d79daeb7991087b9eff388b28c (patch)
tree7af90ae93db1c7527d1e764b7c26a1fb162e9e14 /gnu/packages/golang.scm
parent767a0a18d88479c713f1b9b034bd06eedfe71a80 (diff)
downloadpatches-06c2d0e6c1f8c6d79daeb7991087b9eff388b28c.tar
patches-06c2d0e6c1f8c6d79daeb7991087b9eff388b28c.tar.gz
gnu: Add go-golang-org-x-text-encoding.
* gnu/packages/golang.scm (go-golang-org-x-text-encoding): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 10c30e520b..9b423d0419 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages lua)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages textutils)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
@@ -1174,6 +1175,32 @@ for low-level interaction with the operating system.")
(description "Thi spackage provides @code{cpu}, which offers tools for CPU
feature detection in Go.")))
+(define-public go-golang-org-x-text-encoding
+ (package
+ (name "go-golang-org-x-text-encoding")
+ (version "0.3.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/text")
+ (commit (string-append "v" version))))
+ (file-name (string-append "go.googlesource.com-text-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "0flv9idw0jm5nm8lx25xqanbkqgfiym6619w575p7nrdh0riqwqh"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/text/encoding"
+ #:unpack-path "golang.org/x/text"))
+ (synopsis "Interface for character encodings for conversion to and from
+UTF-8")
+ (description "This package defines an interface for character encodings.
+Specific implementations of encoding for CJK text as well as simple character
+encodings are provided in subpackages.")
+ (home-page "https://go.googlesource.com/text")
+ (license license:bsd-3)))
+
(define-public go-golang-org-x-text-transform
(let ((commit "e19ae1496984b1c655b8044a65c0300a3c878dd3")
(revision "1"))