summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-16 11:27:21 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:02 -0400
commit6d766bec446690fec6a15eaf48cd223a8c2426b3 (patch)
treef2b1e2cf01777a575183e170aec2613fb45c16e6 /gnu/packages/golang.scm
parent8201afdf0cbbba25fb09089c872211178a85fc9d (diff)
downloadpatches-6d766bec446690fec6a15eaf48cd223a8c2426b3.tar
patches-6d766bec446690fec6a15eaf48cd223a8c2426b3.tar.gz
gnu: Add go-github-com-lucas-clemente-quic-go.
* gnu/packages/golang.scm (go-github-com-lucas-clemente-quic-go: New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 45a77c51cc..73f740299b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3556,3 +3556,31 @@ the Go standard library's TLS 1.3 implementation.")
implementation of generics.")
(home-page "https://github.com/cheekybits/genny/")
(license license:expat)))
+
+(define-public go-github-com-lucas-clemente-quic-go
+ (package
+ (name "go-github-com-lucas-clemente-quic-go")
+ (version "0.11.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lucas-clemente/quic-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gqm5mc8alg84ra7yxach34il1jvcij8f76qdqcahnd3d2nhjbia"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/lucas-clemente/quic-go"
+ ;; XXX More packages required...
+ #:tests? #f))
+ (propagated-inputs
+ `(("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+ ("go-github-com-cheekybits-genny" ,go-github-com-cheekybits-genny)
+ ("go-github-com-marten-seemann-qtls" ,go-github-com-marten-seemann-qtls)))
+ (synopsis "QUIC in Go")
+ (description "This package provides a Go language implementation of the QUIC
+network protocol.")
+ (home-page "https://github.com/lucas-clemente/quic-go")
+ (license license:expat)))