summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-27 19:04:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-03-28 09:35:24 +0300
commit56486b3a40958490550e46c122c6ae2ebf608aa3 (patch)
tree7533351e5252c2a446173edadb60108416f7224d /gnu/packages/gnuzilla.scm
parentf403c6761b4b70ce0d67240db2eee3d1d815c7d7 (diff)
downloadpatches-56486b3a40958490550e46c122c6ae2ebf608aa3.tar
patches-56486b3a40958490550e46c122c6ae2ebf608aa3.tar.gz
gnu: mozjs@17: Use 'modify-phases' syntax.
* gnu/packages/gnuzilla.scm (mozjs@17)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index be3e59aa88..3034ee98d1 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -85,31 +85,30 @@
(inputs
`(("zlib" ,zlib)))
(arguments
- `(;; XXX: parallel build fails, lacking:
- ;; mkdir -p "system_wrapper_js/"
- #:parallel-build? #f
- #:phases
- (alist-cons-after 'unpack 'delete-timedout-test
+ `(;; XXX: parallel build fails, lacking:
+ ;; mkdir -p "system_wrapper_js/"
+ #:parallel-build? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-timedout-test
;; This test times out on slower hardware.
- (lambda _ (delete-file "js/src/jit-test/tests/basic/bug698584.js"))
- (alist-cons-before
- 'configure 'chdir
+ (lambda _ (delete-file "js/src/jit-test/tests/basic/bug698584.js")))
+ (add-before 'configure 'chdir
(lambda _
- (chdir "js/src"))
- (alist-replace
- 'configure
- ;; configure fails if it is followed by SHELL and CONFIG_SHELL
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "SHELL" (which "sh"))
- (setenv "CONFIG_SHELL" (which "sh"))
- (zero? (system*
- "./configure" (string-append "--prefix=" out)
- ,@(if (string=? "aarch64-linux"
- (%current-system))
- '("--host=aarch64-unknown-linux-gnu")
- '())))))
- %standard-phases)))))
+ (chdir "js/src")
+ #t))
+ (replace 'configure
+ ;; configure fails if it is followed by SHELL and CONFIG_SHELL
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "SHELL" (which "sh"))
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (zero? (system*
+ "./configure" (string-append "--prefix=" out)
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '())))))))))
(home-page
"https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey")
(synopsis "Mozilla javascript engine")