summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-16 03:52:05 -0500
committerMark H Weaver <mhw@netris.org>2015-01-16 09:14:08 -0500
commit2a666e9cfddc5ec25831618bc376ab4ca6692527 (patch)
treeea21d6d2100179e96b5948a2e3361d838ba0b148 /gnu/packages/gnuzilla.scm
parent57b7e1a62d2269bfd9d37f88bae92c829222f8fc (diff)
downloadpatches-2a666e9cfddc5ec25831618bc376ab4ca6692527.tar
patches-2a666e9cfddc5ec25831618bc376ab4ca6692527.tar.gz
gnu: icecat: Add fixes for CVE-2014-{8634,8638,8639,8641}.
* gnu/packages/patches/icecat-CVE-2014-8634-pt1.patch, gnu/packages/patches/icecat-CVE-2014-8634-pt2.patch, gnu/packages/patches/icecat-CVE-2014-8638-pt1.patch, gnu/packages/patches/icecat-CVE-2014-8638-pt2.patch, gnu/packages/patches/icecat-CVE-2014-8639.patch, gnu/packages/patches/icecat-CVE-2014-8641.patch, gnu/packages/patches/icecat-armhf-xpcom.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 8e397464ac..9c6b39f3d2 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -231,7 +231,14 @@ standards.")
"icecat-CVE-2014-1590.patch"
"icecat-CVE-2014-1592.patch"
"icecat-CVE-2014-1593.patch"
- "icecat-CVE-2014-1594.patch")))))
+ "icecat-CVE-2014-1594.patch"
+ "icecat-armhf-xpcom.patch"
+ "icecat-CVE-2014-8639.patch"
+ "icecat-CVE-2014-8634-pt1.patch"
+ "icecat-CVE-2014-8634-pt2.patch"
+ "icecat-CVE-2014-8641.patch"
+ "icecat-CVE-2014-8638-pt1.patch"
+ "icecat-CVE-2014-8638-pt2.patch")))))
(build-system gnu-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)