summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-09-23 04:46:59 -0400
committerMark H Weaver <mhw@netris.org>2018-09-25 19:58:58 -0400
commit257e3247910610fe24ae1b86f38e85552d53e48c (patch)
tree546fa26fbcc619741776bddeab8e4996be799483 /gnu/packages/gnuzilla.scm
parent3b97a1779f3b65d582b8edc8c154b6414314b946 (diff)
downloadpatches-257e3247910610fe24ae1b86f38e85552d53e48c.tar
patches-257e3247910610fe24ae1b86f38e85552d53e48c.tar.gz
gnu: icecat: Unbundle graphite2 and harfbuzz.
* gnu/packages/patches/icecat-use-system-graphite2+harfbuzz.patch: New file. * gnu/packages/patches/icecat-use-system-graphite2.patch, gnu/packages/patches/icecat-use-system-harfbuzz.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/gnuzilla.scm (icecat)[source]: Add new patch. Delete bundled graphite2 and harfbuzz in snippet. [inputs]: Add graphite2 and harfbuzz. [arguments]: Add --with-system-{graphite2,harfbuzz} to configure flags.
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 653cee93d5..ad83444e3c 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -495,9 +495,8 @@ security standards.")
"0lqx7g79x15941rhjr3qsfwsny6vzc7d7abdmvjy6jjbqkqlc1zl"))
(patches
(list
- (search-patch "icecat-avoid-bundled-libraries.patch")
- ;; FIXME (search-patch "icecat-use-system-harfbuzz.patch")
- ;; FIXME (search-patch "icecat-use-system-graphite2.patch")
+ (search-patch "icecat-avoid-bundled-libraries.patch")
+ (search-patch "icecat-use-system-graphite2+harfbuzz.patch")
(mozilla-patch "icecat-CVE-2018-12385.patch" "80a4a7ef2813" "1vgcbimpnfjqj934v0cryq1g13xac3wfmd4jyhcb5s60x8xyssf5")
(search-patch "icecat-CVE-2018-12383.patch")
(mozilla-patch "icecat-bug-1489744.patch" "6546ee839d30" "11mhvj77r789b428bfxqq5wdx8yr7lbrdjzr8qjj6fw197pldn51")))
@@ -535,8 +534,8 @@ security standards.")
"media/libvpx"
"security/nss"
;; UNBUNDLE-ME "gfx/cairo"
- ;; UNBUNDLE-ME "gfx/harfbuzz"
- ;; UNBUNDLE-ME "gfx/graphite2"
+ "gfx/harfbuzz"
+ "gfx/graphite2"
"js/src/ctypes/libffi"
"db/sqlite3"))
;; Delete .pyc files, typically present in icecat source tarballs
@@ -557,10 +556,10 @@ security standards.")
("glib" ,glib)
("gtk+" ,gtk+)
("gtk+-2" ,gtk+-2)
- ;; UNBUNDLE-ME ("graphite2" ,graphite2)
+ ("graphite2" ,graphite2)
("pango" ,pango)
("freetype" ,freetype)
- ;; UNBUNDLE-ME ("harfbuzz" ,harfbuzz)
+ ("harfbuzz" ,harfbuzz)
("hunspell" ,hunspell)
("libcanberra" ,libcanberra)
("libgnome" ,libgnome)
@@ -643,8 +642,8 @@ security standards.")
"--with-system-icu"
"--with-system-nspr"
"--with-system-nss"
- ;; UNBUNDLE-ME "--with-system-harfbuzz"
- ;; UNBUNDLE-ME "--with-system-graphite2"
+ "--with-system-harfbuzz"
+ "--with-system-graphite2"
"--enable-system-pixman"
;; UNBUNDLE-ME "--enable-system-cairo"
"--enable-system-ffi"
@@ -697,7 +696,7 @@ security standards.")
all)))
#t))
(add-after 'patch-source-shebangs 'patch-cargo-checksums
- (lambda* _
+ (lambda _
(use-modules (guix build cargo-build-system))
(let ((null-file "/dev/null")
(null-hash "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"))