summaryrefslogtreecommitdiff
path: root/gnu/packages/gnutls.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /gnu/packages/gnutls.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadpatches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar
patches-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'gnu/packages/gnutls.scm')
-rw-r--r--gnu/packages/gnutls.scm98
1 files changed, 98 insertions, 0 deletions
diff --git a/gnu/packages/gnutls.scm b/gnu/packages/gnutls.scm
new file mode 100644
index 0000000000..4bda9a9ac5
--- /dev/null
+++ b/gnu/packages/gnutls.scm
@@ -0,0 +1,98 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gnutls)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages base)
+ #:use-module ((gnu packages compression)
+ #:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (gnu packages nettle)
+ #:use-module (gnu packages guile)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages which))
+
+(define-public libtasn1
+ (package
+ (name "libtasn1")
+ (version "3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/libtasn1/libtasn1-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gvgndypwicchf7m660zh7jdgmkfj9g9xavpcc08pyd0120y0bk7"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/libtasn1/")
+ (synopsis "GNU Libtasn1, an ASN.1 library")
+ (description
+ "Libtasn1 is the ASN.1 library used by GnuTLS, GNU Shishi and some
+other packages. The goal of this implementation is to be highly
+portable, and only require an ANSI C89 platform.")
+ (license lgpl2.0+)))
+
+(define-public gnutls
+ (package
+ (name "gnutls")
+ (version "3.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnu/gnutls/gnutls-"
+ version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "0zsybr9plllk1phh83bx9bg7c5ccik427j4n3k1s9fiy4j69n0w3"))))
+ (build-system gnu-build-system)
+
+ ;; Build of the Guile bindings is not parallel-safe. See
+ ;; <http://git.savannah.gnu.org/cgit/gnutls.git/commit/?id=330995a920037b6030ec0282b51dde3f8b493cad>
+ ;; for the actual fix.
+ (arguments '(#:parallel-build? #f))
+
+ (inputs
+ `(("guile" ,guile-2.0)
+ ;; ("lzo" ,lzo)
+ ("zlib" ,guix:zlib)
+ ("perl" ,perl)))
+ (propagated-inputs
+ `(("libtasn1" ,libtasn1)
+ ("nettle" ,nettle)
+ ("which" ,which)))
+ (home-page "http://www.gnu.org/software/gnutls/")
+ (synopsis
+ "The GNU Transport Layer Security Library")
+ (description
+ "GnuTLS is a project that aims to develop a library which provides
+a secure layer, over a reliable transport layer. Currently the GnuTLS
+library implements the proposed standards by the IETF's TLS working
+group.
+
+Quoting from the TLS protocol specification:
+
+\"The TLS protocol provides communications privacy over the
+Internet. The protocol allows client/server applications to communicate
+in a way that is designed to prevent eavesdropping, tampering, or
+message forgery.\"")
+ (license lgpl2.1+)))