summaryrefslogtreecommitdiff
path: root/gnu/packages/gnutls.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-06-27 23:57:45 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-06-28 17:26:49 +0200
commit013ce67b193326f4dfbdddb3c6445d542476bd93 (patch)
tree119e910de17340d748f84f5e997abf675df51ffd /gnu/packages/gnutls.scm
parent88a0b7b05127b1e1ca6672ead75925249f9fa114 (diff)
downloadpatches-013ce67b193326f4dfbdddb3c6445d542476bd93.tar
patches-013ce67b193326f4dfbdddb3c6445d542476bd93.tar.gz
gnutls: fix the test-suite for 32 bits systems.
* gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch: New file. * gnu-system.am: Add it here... * gnu/packages/gnutls.scm (gnutls): ... and use it here. Thanks to Nikos Mavrogiannopoulos for providing this patch: http://permalink.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/6778
Diffstat (limited to 'gnu/packages/gnutls.scm')
-rw-r--r--gnu/packages/gnutls.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnutls.scm b/gnu/packages/gnutls.scm
index 32726f6258..d636a9c927 100644
--- a/gnu/packages/gnutls.scm
+++ b/gnu/packages/gnutls.scm
@@ -23,6 +23,7 @@
#:use-module (guix build-system gnu)
#:use-module ((gnu packages compression)
#:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (gnu packages)
#:use-module (gnu packages nettle)
#:use-module (gnu packages guile)
#:use-module (gnu packages perl)
@@ -65,12 +66,18 @@ portable, and only require an ANSI C89 platform.")
(base32
"1zi2kq3vcbqdy9khl7r6pgk4hgwibniasm9k6siasdvqjijq3ymb"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:patches (list (assoc-ref %build-inputs
+ "patch/fix-tests"))
+ #:patch-flags '("-p0")))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("guile" ,guile-2.0)
("zlib" ,guix:zlib)
- ("perl" ,perl)))
+ ("perl" ,perl)
+ ("patch/fix-tests"
+ ,(search-patch "gnutls-fix-tests-on-32-bits-system.patch"))))
(propagated-inputs
`(("libtasn1" ,libtasn1)
("nettle" ,nettle)