summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-08-26 23:47:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-08-26 23:58:55 +0200
commitec0897638eeb64528597ab91aa93e50a821605fc (patch)
tree6787f7d785569fa2d3671ac587e08009f4db6fe9 /gnu/packages/gnupg.scm
parentfeb995c4c97c30aa05e379a145d2d1a086c8eb52 (diff)
downloadpatches-ec0897638eeb64528597ab91aa93e50a821605fc.tar
patches-ec0897638eeb64528597ab91aa93e50a821605fc.tar.gz
gnu: python-gnupg: Fix broken tests.
* gnu/packages/gnupg.scm (python-gnupg)[arguments]: Fix check phase.
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 96c9896018..c78e9d87ec 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Nils Gillmann <ng0@libertad.pw>
;;;
@@ -447,20 +448,18 @@ decrypt messages using the OpenPGP format by making use of GPGME.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "test_gnupg.py"
- ;; Test keyrings are missing, so this test fails.
- (("'test_scan_keys'") "True")
- (("def test_scan_keys") "def disabled__scan_keys")
- ;; Unsure why this test fails.
- (("'test_search_keys'") "True")
- (("def test_search_keys") "def disabled__search_keys"))
- (setenv "GPGBINARY" "gpg")
- (setenv "USERNAME" "guixbuilder")
- ;; The doctests are extremely slow and sometimes time out,
- ;; so we disable them.
- (zero? (system* "python"
- "test_gnupg.py" "--no-doctests")))))))
+ (lambda _
+ (substitute* "test_gnupg.py"
+ ;; Exported keys don't have a version line!
+ (("del k1\\[1\\]") "#")
+ ;; Unsure why this test fails.
+ (("'test_search_keys'") "True")
+ (("def test_search_keys") "def disabled__search_keys"))
+ (setenv "USERNAME" "guixbuilder")
+ ;; The doctests are extremely slow and sometimes time out,
+ ;; so we disable them.
+ (zero? (system* "python"
+ "test_gnupg.py" "--no-doctests")))))))
(native-inputs
`(("gnupg" ,gnupg-1)))
(home-page "https://packages.python.org/python-gnupg/index.html")