summaryrefslogtreecommitdiff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
authorMike Gerwitz <mtg@gnu.org>2016-10-22 12:06:02 -0400
committerMarius Bakke <mbakke@fastmail.com>2016-10-27 09:56:54 +0100
commitcd9ed6c1cbd9fdcfa38825b8109a646fb968b7a8 (patch)
treee68529edb92f778b08703816902e3915edb72586 /gnu/packages/gnupg.scm
parenta6b256affc94bce215003e52de50ed3fa6fc0106 (diff)
downloadpatches-cd9ed6c1cbd9fdcfa38825b8109a646fb968b7a8.tar
patches-cd9ed6c1cbd9fdcfa38825b8109a646fb968b7a8.tar.gz
gnu: gnupg: Add support for pcsc-lite.
* gnu/packages/gnupg.scm (gnupg)[inputs]: Add pcsc-lite. [arguments]: Rename phase 'patch-config-files' to 'patch-paths'. Patch `scd/scdaemon.c' with absolute path of libpcsclite.so. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 5fcc03a222..60c43abda1 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Nils Gillmann <ng0@libertad.pw>
;;; Copyright © 2016 Christopher Baines <mail@cbaines.net>
+;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,6 +44,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages security-token)
#:use-module (gnu packages tls)
#:use-module (guix packages)
#:use-module (guix download)
@@ -261,6 +263,7 @@ compatible to GNU Pth.")
("libksba" ,libksba)
("npth" ,npth)
("openldap" ,openldap)
+ ("pcsc-lite" ,pcsc-lite)
("readline" ,readline)
("sqlite" ,sqlite)
("zlib" ,zlib)))
@@ -268,10 +271,14 @@ compatible to GNU Pth.")
`(#:configure-flags '("--enable-gpg2-is-gpg")
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'patch-config-files
- (lambda _
+ (add-before 'configure 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "tests/openpgp/defs.inc"
(("/bin/pwd") (which "pwd")))
+ (substitute* "scd/scdaemon.c"
+ (("\"(libpcsclite\\.so[^\"]*)\"" _ name)
+ (string-append "\"" (assoc-ref inputs "pcsc-lite")
+ "/lib/" name "\"")))
#t)))))
(home-page "https://gnupg.org/")
(synopsis "GNU Privacy Guard")